summaryrefslogtreecommitdiffstats
path: root/source/configure.in
diff options
context:
space:
mode:
authorJeremy Allison <jra@samba.org>1999-01-26 02:18:44 +0000
committerJeremy Allison <jra@samba.org>1999-01-26 02:18:44 +0000
commitafcb12358e3127b296347043a09dd91c21df49b2 (patch)
tree2d8a79402a36f7c2c828e9fec2f23c854eef2b06 /source/configure.in
parent22735196e4e16e8953fc497cd5f09798036b31f0 (diff)
downloadsamba-afcb12358e3127b296347043a09dd91c21df49b2.tar.gz
samba-afcb12358e3127b296347043a09dd91c21df49b2.tar.xz
samba-afcb12358e3127b296347043a09dd91c21df49b2.zip
Makefile.in: Removed SMB_PASSGRP_FILE - not used anywhere. Added --with-lockdir to
allow HP to specify where they want the /usr/local/samba/var/locks directory to go. local.h: Added DEFAULT_PASSWD_CHAT to allow it to be changed. param/loadparm.c: Use DEFAULT_PASSWD_CHAT and also re-arranged HPUX printing. Jeremy.
Diffstat (limited to 'source/configure.in')
-rw-r--r--source/configure.in21
1 files changed, 21 insertions, 0 deletions
diff --git a/source/configure.in b/source/configure.in
index 82e512bf518..7edf9c35b5d 100644
--- a/source/configure.in
+++ b/source/configure.in
@@ -1233,6 +1233,27 @@ AC_ARG_WITH(privatedir,
)
#################################################
+# set lock directory location
+AC_ARG_WITH(lockdir,
+[ --with-lockdir=DIR Where to put lock files ($ac_default_prefix/var/locks)],
+[ case "$withval" in
+ yes|no)
+ #
+ # Just in case anybody calls it without argument
+ #
+ AC_MSG_WARN([--with-lockdir called without argument - will use default])
+ lockdir='$(VARDIR)/locks'
+ ;;
+ * )
+ lockdir="$withval"
+ ;;
+ esac
+ AC_SUBST(lockdir)],
+ [lockdir='$(VARDIR)/locks'
+ AC_SUBST(lockdir)]
+)
+
+#################################################
# set SWAT directory location
AC_ARG_WITH(swatdir,
[ --with-swatdir=DIR Where to put SWAT files ($ac_default_prefix/swat)],