summaryrefslogtreecommitdiffstats
path: root/source/configure.in
diff options
context:
space:
mode:
authorAndrew Tridgell <tridge@samba.org>1998-10-23 01:51:31 +0000
committerAndrew Tridgell <tridge@samba.org>1998-10-23 01:51:31 +0000
commita66c56d70e7e663f3a19cbfcc2e704653d8fc9b2 (patch)
treef358390d665532638617555cd10c1d18f4b18bd7 /source/configure.in
parent252fe1e7014b2bf79a3abfa52fb77db9129074c7 (diff)
downloadsamba-a66c56d70e7e663f3a19cbfcc2e704653d8fc9b2.tar.gz
samba-a66c56d70e7e663f3a19cbfcc2e704653d8fc9b2.tar.xz
samba-a66c56d70e7e663f3a19cbfcc2e704653d8fc9b2.zip
don't enable smbsh/smbwrapper on systems where we can't work out how
to generate PIC code
Diffstat (limited to 'source/configure.in')
-rw-r--r--source/configure.in8
1 files changed, 8 insertions, 0 deletions
diff --git a/source/configure.in b/source/configure.in
index 7cbfe0efa6b..284b721f3c4 100644
--- a/source/configure.in
+++ b/source/configure.in
@@ -9,6 +9,7 @@ AC_SUBST(SHELL)
AC_SUBST(MPROGS)
AC_SUBST(LDSHFLAGS)
AC_SUBST(HOST_OS)
+AC_SUBST(WRAP)
AC_SUBST(WRAP32)
AC_SUBST(PICFLAG)
AC_PROG_AWK
@@ -70,6 +71,13 @@ if test x$PICFLAG = x; then
fi
fi
+# we can only support smbsh and smbwrapper if we can produce PIC code
+if test x$PICFLAG = x; then
+ echo No support for PIC code - disabling smbwrapper and smbsh
+ WRAP=""
+else
+ WRAP="bin/smbsh bin/smbwrapper.so"
+fi
AC_INLINE
AC_HEADER_STDC