summaryrefslogtreecommitdiffstats
path: root/source/configure.in
diff options
context:
space:
mode:
authorJeremy Allison <jra@samba.org>1998-11-14 01:04:13 +0000
committerJeremy Allison <jra@samba.org>1998-11-14 01:04:13 +0000
commit9ee8f39aed8772a05c203161b4ae6b7d90d67481 (patch)
tree07778a1272b86bb89046485d4eda6054d1d24edf /source/configure.in
parent9e1ff71faf558addfabe038e3bf45ee694ea4a0b (diff)
downloadsamba-9ee8f39aed8772a05c203161b4ae6b7d90d67481.tar.gz
samba-9ee8f39aed8772a05c203161b4ae6b7d90d67481.tar.xz
samba-9ee8f39aed8772a05c203161b4ae6b7d90d67481.zip
Removed acconfig.h configure configure.in include/config.h.in: Made smbwrapper not made
by default. nmbd*: Changed all calls to namestr() to nmbd_namestr() to fix broken FreeBSD include file problem...sigh. Jeremy.
Diffstat (limited to 'source/configure.in')
-rw-r--r--source/configure.in51
1 files changed, 38 insertions, 13 deletions
diff --git a/source/configure.in b/source/configure.in
index 5b6bfcdbea6..65c31d434fc 100644
--- a/source/configure.in
+++ b/source/configure.in
@@ -206,7 +206,7 @@ case "$host_os" in
*bsd*) LDSHFLAGS="-shared -Bshareable"
;;
*irix*) AC_DEFINE(IRIX)
- WRAP32=bin/smbwrapper.32.so
+ ATTEMPT_WRAP32_BUILD=yes
;;
*aix*) AC_DEFINE(AIX);;
*hpux*) AC_DEFINE(HPUX);;
@@ -237,18 +237,6 @@ if test x$PICFLAG = x; then
fi
fi
-WRAP="bin/smbsh bin/smbwrapper.so"
-
-# Conditions under which smbwrapper should not be built.
-
-if test x$PICFLAG = x; then
- echo No support for PIC code - disabling smbwrapper and smbsh
- WRAP=""
-elif test x$ac_cv_func_syscall = xno; then
- AC_MSG_RESULT([No syscall() -- disabling smbwrapper and smbsh])
- WRAP=""
-fi
-
################
AC_CACHE_CHECK([for long long],samba_cv_have_longlong,[
@@ -553,6 +541,43 @@ if test x"$samba_cv_HAVE_SYSV_IPC" = x"yes"; then
fi
#################################################
+# check for smbwrapper support
+AC_MSG_CHECKING(whether to use smbwrapper)
+AC_ARG_WITH(smbwrapper,
+[ --with-smbwrapper Include SMB wrapper support
+ --without-smbwrapper Don't include SMB wrapper support (default)],
+[ case "$withval" in
+ yes)
+ AC_MSG_RESULT(yes)
+ AC_DEFINE(WITH_SMBWRAPPER)
+ WRAP="bin/smbsh bin/smbwrapper.so"
+
+ if test x$ATTEMPT_WRAP32_BUILD = x; then
+ WRAP32=""
+ else
+ WRAP32=bin/smbwrapper.32.so
+ fi
+
+# Conditions under which smbwrapper should not be built.
+
+ if test x$PICFLAG = x; then
+ echo No support for PIC code - disabling smbwrapper and smbsh
+ WRAP=""
+ WRAP32=""
+ elif test x$ac_cv_func_syscall = xno; then
+ AC_MSG_RESULT([No syscall() -- disabling smbwrapper and smbsh])
+ WRAP=""
+ WRAP32=""
+ fi
+ ;;
+ *)
+ AC_MSG_RESULT(no)
+ ;;
+ esac ],
+ AC_MSG_RESULT(no)
+)
+
+#################################################
# check for the AFS filesystem
AC_MSG_CHECKING(whether to use AFS)
AC_ARG_WITH(afs,