summaryrefslogtreecommitdiffstats
path: root/source/configure.in
diff options
context:
space:
mode:
authorJeremy Allison <jra@samba.org>1999-01-13 04:17:24 +0000
committerJeremy Allison <jra@samba.org>1999-01-13 04:17:24 +0000
commit9c788ae1445337a703bf49762ca6ae48abcc8732 (patch)
treebf74708dd072a030f3f2ca563964f5511e8b788a /source/configure.in
parent9a261d37a693aee7e600d0fd9343e8da5d3f2bb5 (diff)
downloadsamba-9c788ae1445337a703bf49762ca6ae48abcc8732.tar.gz
samba-9c788ae1445337a703bf49762ca6ae48abcc8732.tar.xz
samba-9c788ae1445337a703bf49762ca6ae48abcc8732.zip
configure configure.in: Fixed the compile problem with Solaris 2.6/2.7 and
gcc2.7.x - this condition is now auto detected and uses the correct flags. smbd/reply.c: Did more mapping for 64-bit lock requests on 32 bit systems. smbd/nttrans.c: smbd/oplock.c: Fixed the MS-Office not noticing files are open problem. This was a *subtle* problem and now needs testing to ensure the fix is correct. It's past 8pm, I'm tired and I'm going for a pizza. Jeremy.
Diffstat (limited to 'source/configure.in')
-rw-r--r--source/configure.in23
1 files changed, 22 insertions, 1 deletions
diff --git a/source/configure.in b/source/configure.in
index 0fac3141ef1..bfa9194a7e1 100644
--- a/source/configure.in
+++ b/source/configure.in
@@ -60,6 +60,7 @@ case "$host_os" in
#
case `uname =r` in
*10*|*11*)
+ AC_MSG_RESULT([enabling large file support])
CPPFLAGS="$CPPFLAGS -D_LARGEFILE64_SOURCE"
;;
esac
@@ -69,17 +70,37 @@ case "$host_os" in
# files *at all* unless the -D_LARGE_FILE or -D_LARGE_FILE_API flags are set.
#
*aix4*)
+ AC_MSG_RESULT([enabling large file support])
CPPFLAGS="$CPPFLAGS -D_LARGE_FILES"
;;
#
# Defines needed for Solaris 2.6/2.7 aka 7.0 to make it admit
# to the existance of large files..
+# Note that -D_LARGEFILE64_SOURCE is different from the Sun
+# recommendations on large file support, however it makes the
+# compile work using gcc 2.7 and 2.8, whereas using the Sun
+# recommendation makes the compile fail on gcc2.7. JRA.
#
*solaris*)
case `uname -r` in
5.6*|5.7*)
+ AC_MSG_RESULT([enabling large file support])
+ if test "$ac_cv_prog_gcc" = yes; then
+ ${CC-cc} -v >conftest.c 2>&1
+ ac_cv_gcc_compiler_version_number=`grep 'gcc version' conftest.c`
+ rm -fr conftest.c
+ case "$ac_cv_gcc_compiler_version_number" in
+ "*gcc version 2.6*"|"*gcc version 2.7*")
+ CPPFLAGS="$CPPFLAGS -D_LARGEFILE64_SOURCE"
+ ;;
+ *)
+ CPPFLAGS="$CPPFLAGS -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64"
+ ;;
+ esac
+ else
CPPFLAGS="$CPPFLAGS -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64"
- ;;
+ fi
+ ;;
esac
;;
#