summaryrefslogtreecommitdiffstats
path: root/source/configure.in
diff options
context:
space:
mode:
authorJeremy Allison <jra@samba.org>1998-12-22 02:53:06 +0000
committerJeremy Allison <jra@samba.org>1998-12-22 02:53:06 +0000
commit80810371e6ee2ed33cb22a3629373131e92a7ab4 (patch)
treeaddea2df3e938f8c84c27481715c02570930f06a /source/configure.in
parenta26d050828ede44d2beeb01edfa7bddd0c6deac0 (diff)
downloadsamba-80810371e6ee2ed33cb22a3629373131e92a7ab4.tar.gz
samba-80810371e6ee2ed33cb22a3629373131e92a7ab4.tar.xz
samba-80810371e6ee2ed33cb22a3629373131e92a7ab4.zip
Rather large (I'm afraid) tidyup of the setuid handling code.
All setuid code now resides in the one module lib/util_sec.c. The interfaces this module exports are : void gain_root_privilage(void); - Set real/eff/saved uid's to 0. void gain_root_group_privilage(void); - Set real/eff/saved gid's to 0. int set_effective_uid(uid_t uid); - Set eff uid *only* to given value. int set_effective_gid(gid_t gid); - Set eff gid *only* to given value. BOOL become_user_permanently(uid_t uid, gid_t gid); - Set real/eff/saved uid's and gid's to uid and gid permanently - with no way back to root. Most of the quota code now uses these calls (except for a few special cases). smbd/chgpasswd.c: Ensured the dochild exits in the fork()'d child. libsmb/nmblib.c: Fix from Jasper for memory leak. Jeremy.
Diffstat (limited to 'source/configure.in')
-rw-r--r--source/configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/source/configure.in b/source/configure.in
index 5dc298a0dd4..347dcb26763 100644
--- a/source/configure.in
+++ b/source/configure.in
@@ -267,7 +267,7 @@ AC_CHECK_FUNCS(waitpid getcwd strdup strtoul strerror chown chmod chroot)
AC_CHECK_FUNCS(fstat strchr utime utimes getrlimit fsync execl bzero memset)
AC_CHECK_FUNCS(memmove vsnprintf snprintf setsid glob strpbrk pipe crypt16 getauthuid)
AC_CHECK_FUNCS(strftime sigprocmask sigblock sigaction innetgr setnetgrent getnetgrent endnetgrent)
-AC_CHECK_FUNCS(initgroups select rdchk getgrnam pathconf )
+AC_CHECK_FUNCS(initgroups select rdchk getgrnam pathconf setreuid setregid seteuid setegid)
AC_CHECK_FUNCS(setuidx setgroups mktime rename ftruncate stat64 fstat64 lstat64 fopen64)
AC_CHECK_FUNCS(atexit grantpt dup2 lseek64 ftruncate64 readdir64)
AC_CHECK_FUNCS(fseek64 fseeko64 ftell64 ftello64 setluid yp_get_default_domain getpwanam)