summaryrefslogtreecommitdiffstats
path: root/source/configure.in
diff options
context:
space:
mode:
authorJeremy Allison <jra@samba.org>1998-12-06 20:29:22 +0000
committerJeremy Allison <jra@samba.org>1998-12-06 20:29:22 +0000
commit68a950a941015e776520890d28ba0488bd061a8e (patch)
tree096b7ed71ff0648252f28f8586de912cc900dfde /source/configure.in
parent46df7f141586b104e4d60e543d98a9562b10809a (diff)
downloadsamba-68a950a941015e776520890d28ba0488bd061a8e.tar.gz
samba-68a950a941015e776520890d28ba0488bd061a8e.tar.xz
samba-68a950a941015e776520890d28ba0488bd061a8e.zip
Fixes to get Solaris 2.6/2.7 large file support.
Fix test for getresgid. Jeremy.
Diffstat (limited to 'source/configure.in')
-rw-r--r--source/configure.in19
1 files changed, 15 insertions, 4 deletions
diff --git a/source/configure.in b/source/configure.in
index bbe28cb2bf8..fd8c11ec273 100644
--- a/source/configure.in
+++ b/source/configure.in
@@ -38,13 +38,24 @@ case "$host_os" in
fi
;;
#
-# AIX4.x is *so* broken. It doesn't even admit to having large
+# AIX4.x doesn't even admit to having large
# files *at all* unless the -D_LARGE_FILE or -D_LARGE_FILE_API flags are set.
#
*aix4*)
CPPFLAGS="$CPPFLAGS -D_LARGE_FILES"
;;
#
+# Defines needed for Solaris 2.6/2.7 aka 7.0 to make it admit
+# to the existance of large files..
+#
+ *solaris*)
+ case `uname -r` in
+ 5.6*|5.7*)
+ CPPFLAGS="$CPPFLAGS -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64"
+ ;;
+ esac
+ ;;
+#
# Tests needed for SINIX large file support.
#
*sysv4*)
@@ -156,9 +167,9 @@ fi
# Do the same check for setresguid...
#
AC_CACHE_CHECK([for real setresgid],samba_cv_have_setresgid,[
- AC_TRY_RUN([#include <errno.h>
-main() { setresgid(1,1,1); setresgid(2,2,2); exit(errno==EPERM?0:1);}],
- samba_cv_have_setresgid=yes,samba_cv_have_setresgid=no,samba_cv_have_setresgid=cross)])
+ AC_TRY_COMPILE([#include <errno.h>
+main() { setresgid(1,1,1); exit(0);}],
+ samba_cv_have_setresgid=yes,samba_cv_have_setresgid=no)])
if test x"$samba_cv_have_setresgid" = x"yes"; then
AC_DEFINE(HAVE_SETRESGID)
fi