summaryrefslogtreecommitdiffstats
path: root/source/configure.in
diff options
context:
space:
mode:
authorJeremy Allison <jra@samba.org>1998-12-11 00:24:23 +0000
committerJeremy Allison <jra@samba.org>1998-12-11 00:24:23 +0000
commit5df1a097cd4324965bd3e7a17d20b69109f0348e (patch)
tree5cd9ca719001d8b422506bf0d3e0469e3a63ae97 /source/configure.in
parentbd61029e2ad2cec7751a251fccd2dbf709175fc9 (diff)
downloadsamba-5df1a097cd4324965bd3e7a17d20b69109f0348e.tar.gz
samba-5df1a097cd4324965bd3e7a17d20b69109f0348e.tar.xz
samba-5df1a097cd4324965bd3e7a17d20b69109f0348e.zip
Fixed configure bug with RedHat 5.1 where it uses setresgid even though
this is not yet implemented. Jeremy.
Diffstat (limited to 'source/configure.in')
-rw-r--r--source/configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/source/configure.in b/source/configure.in
index cf730e8f2bc..3554cddba57 100644
--- a/source/configure.in
+++ b/source/configure.in
@@ -190,7 +190,7 @@ fi
AC_CACHE_CHECK([for real setresgid],samba_cv_have_setresgid,[
AC_TRY_RUN([#include <unistd.h>
#include <errno.h>
-main() { setresgid(1,1,1); exit(0);}],
+main() { errno = 0; setresgid(1,1,1); exit(errno != 0 ? (errno==EPERM ? 0 : 1) : 0);}],
samba_cv_have_setresgid=yes,samba_cv_have_setresgid=no)])
if test x"$samba_cv_have_setresgid" = x"yes"; then
AC_DEFINE(HAVE_SETRESGID)