summaryrefslogtreecommitdiffstats
path: root/source/configure.in
diff options
context:
space:
mode:
authorJeremy Allison <jra@samba.org>1998-11-19 19:56:23 +0000
committerJeremy Allison <jra@samba.org>1998-11-19 19:56:23 +0000
commit50fdf7b82b2f8611c008a76f08ef5bfa91fdf75d (patch)
treea2574c3c3148ee5992023c7af4c879e8e1d3d2ed /source/configure.in
parent06d88879038618949e603f7c56773536e95bab4d (diff)
downloadsamba-50fdf7b82b2f8611c008a76f08ef5bfa91fdf75d.tar.gz
samba-50fdf7b82b2f8611c008a76f08ef5bfa91fdf75d.tar.xz
samba-50fdf7b82b2f8611c008a76f08ef5bfa91fdf75d.zip
Fixes for autoconf on HPUX. Includes ANSI -Ae flag test for HPUX
compiler and check for getspnam in -lsec. Jeremy.
Diffstat (limited to 'source/configure.in')
-rw-r--r--source/configure.in19
1 files changed, 19 insertions, 0 deletions
diff --git a/source/configure.in b/source/configure.in
index 8c214ce9e56..0a3195199e8 100644
--- a/source/configure.in
+++ b/source/configure.in
@@ -25,6 +25,16 @@ AC_CANONICAL_SYSTEM
AC_VALIDATE_CACHE_SYSTEM_TYPE
SAMBA_MAINTAINER_MODE
+# try to work out if this compiler uses the HPUX -Ae flag.
+case "$host_os" in
+ *hpux*)
+ AC_PROG_CC_FLAG(Ae)
+ if test $ac_cv_prog_cc_Ae = yes; then
+ CPPFLAGS="$CPPFLAGS -Ae"
+ fi
+ ;;
+esac
+
AC_INLINE
AC_HEADER_STDC
AC_HEADER_DIRENT
@@ -205,6 +215,15 @@ if test x"$ac_cv_func_set_auth_parameters" = x"no"; then
AC_DEFINE(HAVE_SET_AUTH_PARAMETERS)])
fi
+#
+# This next check is needed for HPUX,
+# again, shouldn't hurt anywhere else.
+#
+if test x"$ac_cv_func_getspnam" = x"no"; then
+ AC_CHECK_LIB(sec, getspnam, [LIBS="$LIBS -lsec";
+ AC_DEFINE(HAVE_GETSPNAM)])
+fi
+
# this bit needs to be modified for each OS that is suported by
# smbwrapper. You need to specify how to created a shared library and
# how to compile C code to produce PIC object files