summaryrefslogtreecommitdiffstats
path: root/source/configure.in
diff options
context:
space:
mode:
authorJeremy Allison <jra@samba.org>1998-10-15 00:55:17 +0000
committerJeremy Allison <jra@samba.org>1998-10-15 00:55:17 +0000
commit475992730c0ecbf31c09b3518df2f0354cec61da (patch)
tree908f12d5f2eea0978f2a5066f70328ccf6314623 /source/configure.in
parent53805112f1a301f77cda93b68e6fa3054895f20f (diff)
downloadsamba-475992730c0ecbf31c09b3518df2f0354cec61da.tar.gz
samba-475992730c0ecbf31c09b3518df2f0354cec61da.tar.xz
samba-475992730c0ecbf31c09b3518df2f0354cec61da.zip
config: Fix crypt prototype on RedHat Linux.
include/includes.h: Fix crypt prototype on RedHat Linux. smbd/fileio.c: Fix mmap bug found by WinCE client. smbd/ipc.c: Fix WinCE wierdness with pipes being opened as \server\pipe\lanman smbd/password.c: Fix encrypted null passwords. Jeremy.
Diffstat (limited to 'source/configure.in')
-rw-r--r--source/configure.in8
1 files changed, 8 insertions, 0 deletions
diff --git a/source/configure.in b/source/configure.in
index 1cfeb1a3b47..dc036c6238a 100644
--- a/source/configure.in
+++ b/source/configure.in
@@ -123,6 +123,14 @@ if test x"$samba_cv_have_setresuid_decl" = x"yes"; then
AC_DEFINE(HAVE_SETRESUID_DECL)
fi
+# stupid glibc has the functions but no declaration. grrrr.
+AC_CACHE_CHECK([for crypt declaration],samba_cv_have_crypt_decl,[
+ AC_TRY_COMPILE([#include <unistd.h>],[int i = crypt],
+ samba_cv_have_crypt_decl=yes,samba_cv_have_crypt_decl=no)])
+if test x"$samba_cv_have_crypt_decl" = x"yes"; then
+ AC_DEFINE(HAVE_CRYPT_DECL)
+fi
+
# and glibc has setresuid under linux but the function does
# nothing until kernel 2.1.44! very dumb.
AC_CACHE_CHECK([for real setresuid],samba_cv_have_setresuid,[