summaryrefslogtreecommitdiffstats
path: root/source/configure.in
diff options
context:
space:
mode:
authorJeremy Allison <jra@samba.org>1998-11-18 21:40:29 +0000
committerJeremy Allison <jra@samba.org>1998-11-18 21:40:29 +0000
commit16cc88dc0d372f4bcaba17ec79a51659ea56fb89 (patch)
tree8a27385fca2f6a4e7107b0a13cf7202a6e1fc812 /source/configure.in
parent6946b40d9f5d574450eebf0a90441349e2a35cd8 (diff)
downloadsamba-16cc88dc0d372f4bcaba17ec79a51659ea56fb89.tar.gz
samba-16cc88dc0d372f4bcaba17ec79a51659ea56fb89.tar.xz
samba-16cc88dc0d372f4bcaba17ec79a51659ea56fb89.zip
Added some of the fixes needed for OSF1 (Digital UNIX).
HAVE_PUTPRPWNAM is defined in -lsecurity. <net/route.h> needed to stop compile complaints in <net/if.h> smbpasswd: Moved SunOS optind/optarg to global scope. Jeremy
Diffstat (limited to 'source/configure.in')
-rw-r--r--source/configure.in7
1 files changed, 6 insertions, 1 deletions
diff --git a/source/configure.in b/source/configure.in
index 7cff9218361..c752feb8f27 100644
--- a/source/configure.in
+++ b/source/configure.in
@@ -29,7 +29,7 @@ AC_HEADER_DIRENT
AC_HEADER_TIME
AC_HEADER_SYS_WAIT
AC_CHECK_HEADERS(sys/fcntl.h sys/select.h fcntl.h sys/time.h sys/unistd.h)
-AC_CHECK_HEADERS(unistd.h utime.h grp.h sys/id.h limits.h memory.h net/if.h)
+AC_CHECK_HEADERS(unistd.h utime.h grp.h sys/id.h limits.h memory.h net/route.h net/if.h)
AC_CHECK_HEADERS(compat.h rpc/rpc.h rpc/types.h rpc/xdr.h rpc/auth.h rpc/clnt.h)
AC_CHECK_HEADERS(rpcsvc/yp_prot.h rpcsvc/ypclnt.h sys/param.h ctype.h )
AC_CHECK_HEADERS(sys/wait.h sys/resource.h sys/ioctl.h sys/mode.h)
@@ -190,6 +190,11 @@ AC_CHECK_FUNCS(pread _pread __pread pread64 _pread64 __pread64)
AC_CHECK_FUNCS(pwrite _pwrite __pwrite pwrite64 _pwrite64 __pwrite64)
AC_CHECK_FUNCS(open64 _open64 __open64 creat64)
+if test x"$ac_cv_func_putprpwnam" = x"no"; then
+ AC_CHECK_LIB(security, putprpwnam, [LIBS="$LIBS -lsecurity";
+ AC_DEFINE(HAVE_PUTPRPWNAM)])
+fi
+
# this bit needs to be modified for each OS that is suported by
# smbwrapper. You need to specify how to created a shared library and
# how to compile C code to produce PIC object files