summaryrefslogtreecommitdiffstats
path: root/source/configure.in
diff options
context:
space:
mode:
authorJeremy Allison <jra@samba.org>1998-11-19 04:08:37 +0000
committerJeremy Allison <jra@samba.org>1998-11-19 04:08:37 +0000
commit06d88879038618949e603f7c56773536e95bab4d (patch)
tree3f2ef745373e7970ff7de8d22ff7d61fe65efd8e /source/configure.in
parent8dd61f715ac4e965e7c971509a42f60fd6680d4e (diff)
downloadsamba-06d88879038618949e603f7c56773536e95bab4d.tar.gz
samba-06d88879038618949e603f7c56773536e95bab4d.tar.xz
samba-06d88879038618949e603f7c56773536e95bab4d.zip
Changes to make the default prefix /usr/local/samba - as it was in 1.9.18p10.
acconfig.h configure configure.in include/config.h.in: Fixes to DEC OSF1. libsmb/nmblib.c: Fixes to nmbd jumps in scope names. Jeremy.
Diffstat (limited to 'source/configure.in')
-rw-r--r--source/configure.in11
1 files changed, 11 insertions, 0 deletions
diff --git a/source/configure.in b/source/configure.in
index 24e16d98c7c..8c214ce9e56 100644
--- a/source/configure.in
+++ b/source/configure.in
@@ -1,6 +1,8 @@
dnl Process this file with autoconf to produce a configure script.
AC_INIT(include/includes.h)
AC_CONFIG_HEADER(include/config.h)
+# we want to be compatibe with older versions of Samba
+AC_PREFIX_DEFAULT(/usr/local/samba)
dnl Unique-to-Samba variables we'll be playing with.
AC_SUBST(SHELL)
@@ -189,11 +191,20 @@ AC_CHECK_FUNCS(pread _pread __pread pread64 _pread64 __pread64)
AC_CHECK_FUNCS(pwrite _pwrite __pwrite pwrite64 _pwrite64 __pwrite64)
AC_CHECK_FUNCS(open64 _open64 __open64 creat64)
+#
+# These next two checks are needed for DEC OSF1
+# but don't hurt anywhere else.
+#
if test x"$ac_cv_func_putprpwnam" = x"no"; then
AC_CHECK_LIB(security, putprpwnam, [LIBS="$LIBS -lsecurity";
AC_DEFINE(HAVE_PUTPRPWNAM)])
fi
+if test x"$ac_cv_func_set_auth_parameters" = x"no"; then
+ AC_CHECK_LIB(security, set_auth_parameters, [LIBS="$LIBS -lsecurity";
+ AC_DEFINE(HAVE_SET_AUTH_PARAMETERS)])
+fi
+
# this bit needs to be modified for each OS that is suported by
# smbwrapper. You need to specify how to created a shared library and
# how to compile C code to produce PIC object files