summaryrefslogtreecommitdiffstats
path: root/admin/python-coverage-test-runner.spec
diff options
context:
space:
mode:
Diffstat (limited to 'admin/python-coverage-test-runner.spec')
-rw-r--r--admin/python-coverage-test-runner.spec49
1 files changed, 49 insertions, 0 deletions
diff --git a/admin/python-coverage-test-runner.spec b/admin/python-coverage-test-runner.spec
new file mode 100644
index 0000000..d736ce7
--- /dev/null
+++ b/admin/python-coverage-test-runner.spec
@@ -0,0 +1,49 @@
+%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")}
+
+%global pkgname CoverageTestRunner
+%global prjname coverage-test-runner
+
+Name: python-%{prjname}
+Version: 1.0
+Release: 1%{?dist}
+Summary: Python module for enforcing code coverage completeness
+
+License: GPLv3+
+URL: http://liw.fi/%{prjname}/
+Source0: http://code.liw.fi/%{prjname}/%{pkgname}-%{version}.tar.gz
+
+BuildArch: noarch
+Requires: python-coverage
+
+%description
+CoverageTestRunner is a Python module for running unit tests and
+failing them if the unit test module does not exercise all statements
+in the module it tests.
+
+For example, unit tests in module foo_tests.py are supposed to test
+everything in the foo.py module, and if they don't, it's a bug in the
+test coverage. It does not matter if other tests happen to test the
+missing parts. The unit tests for the module should test everything in
+that module.
+
+
+%prep
+%setup -q -n %{pkgname}-%{version}
+
+
+%build
+%{__python} setup.py build
+
+
+%install
+%{__python} setup.py install -O1 --skip-build --root %{buildroot}
+
+
+%files
+%doc COPYING README
+%{python_sitelib}/*
+
+
+%changelog
+* Sun Jun 3 2012 Michel Salim <salimma@fedoraproject.org> - 1.0-1
+- Initial package