summaryrefslogtreecommitdiffstats
path: root/admin/cmdtest.spec
diff options
context:
space:
mode:
Diffstat (limited to 'admin/cmdtest.spec')
-rw-r--r--admin/cmdtest.spec52
1 files changed, 52 insertions, 0 deletions
diff --git a/admin/cmdtest.spec b/admin/cmdtest.spec
new file mode 100644
index 0000000..85245a6
--- /dev/null
+++ b/admin/cmdtest.spec
@@ -0,0 +1,52 @@
+%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")}
+
+Name: cmdtest
+Version: 0.3
+Release: 1%{?dist}
+Summary: Black-box testing for Unix command line tools
+
+# ask upstream to include license text
+License: GPLv3+
+URL: http://liw.fi/%{name}/
+Source0: http://code.liw.fi/debian/pool/main/c/%{name}/%{name}_%{version}.orig.tar.gz
+
+BuildArch: noarch
+BuildRequires: python-coverage-test-runner
+BuildRequires: python-cliapp
+BuildRequires: python-ttystatus
+Requires: python-cliapp
+Requires: python-ttystatus
+
+%description
+cmdtest black box tests Unix command line tools. Roughly, it is given
+a command line and input files, and the expected output, and it
+verifies that the command line produces the expected output. If not,
+it reports a problem, and shows the differences.
+
+
+%prep
+%setup -q
+
+
+%build
+%{__python} setup.py build
+
+
+%install
+%{__python} setup.py install -O1 --skip-build --root %{buildroot}
+
+
+%check
+%{__python} setup.py check
+
+
+%files
+%doc NEWS README
+%{_mandir}/man1/cmdtest.1*
+%{_bindir}/cmdtest
+%{python_sitelib}/*
+
+
+%changelog
+* Sun Jun 3 2012 Michel Salim <salimma@fedoraproject.org> - 0.3-1
+- Initial package