summaryrefslogtreecommitdiffstats
path: root/initscripts.spec
diff options
context:
space:
mode:
Diffstat (limited to 'initscripts.spec')
-rw-r--r--initscripts.spec37
1 files changed, 35 insertions, 2 deletions
diff --git a/initscripts.spec b/initscripts.spec
index 1314cfdb..6ada8419 100644
--- a/initscripts.spec
+++ b/initscripts.spec
@@ -1,6 +1,8 @@
+%define with_upstart 1%{nil}
+
Summary: The inittab file and the /etc/init.d scripts
Name: initscripts
-Version: 8.67
+Version: 8.68
# ppp-watch is GPLv2+, everything else is GPLv2
License: GPLv2 and GPLv2+
Group: System Environment/Base
@@ -13,7 +15,12 @@ Requires: /sbin/fuser, /bin/grep
Requires: /sbin/pidof
Requires: module-init-tools
Requires: util-linux >= 2.10s-11, mount >= 2.11l
-Requires: bash >= 3.0, SysVinit >= 2.85-38
+Requires: bash >= 3.0
+%if with_upstart
+Requires: upstart
+%else
+Requires: SysVinit >= 2.85-38
+%endif
Requires: /sbin/ip, /sbin/arping, net-tools
Requires: /etc/redhat-release, dev
Requires: ethtool >= 1.8-2, /sbin/runuser
@@ -51,6 +58,13 @@ make ROOT=$RPM_BUILD_ROOT SUPERUSER=`id -un` SUPERGROUP=`id -gn` mandir=%{_mandi
%find_lang %{name}
+%if with_upstart
+ mv -f $RPM_BUILD_ROOT/etc/inittab.upstart $RPM_BUILD_ROOT/etc/inittab
+%else
+ mv -f $RPM_BUILD_ROOT/etc/inittab.sysv $RPM_BUILD_ROOT/etc/inittab
+%endif
+rm -f $RPM_BUILD_ROOT/etc/inittab.*
+
%ifnarch s390 s390x
rm -f \
$RPM_BUILD_ROOT/etc/sysconfig/network-scripts/ifup-ctc \
@@ -210,6 +224,7 @@ rm -rf $RPM_BUILD_ROOT
%dir /etc/NetworkManager
%dir /etc/NetworkManager/dispatcher.d
/etc/NetworkManager/dispatcher.d/00-netreport
+/etc/NetworkManager/dispatcher.d/05-netfs
%doc sysconfig.txt sysvinitfiles ChangeLog static-routes-ipv6 ipv6-tunnel.howto ipv6-6to4.howto changes.ipv6 COPYING
/var/lib/stateless
%ghost %attr(0600,root,utmp) /var/log/btmp
@@ -217,6 +232,24 @@ rm -rf $RPM_BUILD_ROOT
%ghost %attr(0664,root,utmp) /var/run/utmp
%changelog
+* Fri Apr 4 2008 Bill Nottingham <notting@redhat.com> - 8.68-1
+- netfs: umount 'ncp' filesystems as well (#437117)
+- improve performance of s390 ccw rules (#437110, <mernst@de.ibm.com>)
+- fix consoletype environment leak (#439546)
+- ifdown-eth: make sure NEWCONFIG exists before grepping for it (#390271, continued)
+- console_check: always open with NONBLOCK, clear the serial structs first,
+ handle non-16550 ports (<dwmw2@infradead.org>)
+- halt: don't use /etc/sysconfig/clock (#438337)
+- ifup: don't attempt to re-enslave already-enslaved devices (#440077)
+- netfs: run as a NetworkManagerDispatcher script (#439242)
+- netfs: remove $local_fs from the list of provides (making it implicitly provided
+ by booting)
+- serial: add a crude hack to wait for runlevels to finish (#437379)
+- serial: frob /etc/securetty when necessary (#437381)
+- add a upstart-specific inittab
+- translation updates: as, bn_IN, cs, de, es, fi, fr, gu, hi, it, ja, kn, ml, mr, nb,
+ nl, pa, pl, pt_BR, ru, sk, sr, ta, te, zh_CN
+
* Tue Mar 11 2008 Bill Nottingham <notting@redhat.com> - 8.67-1
- actually, don't