summaryrefslogtreecommitdiffstats
path: root/cross-binutils.spec
diff options
context:
space:
mode:
Diffstat (limited to 'cross-binutils.spec')
-rw-r--r--cross-binutils.spec59
1 files changed, 49 insertions, 10 deletions
diff --git a/cross-binutils.spec b/cross-binutils.spec
index 624ad20..729fbe3 100644
--- a/cross-binutils.spec
+++ b/cross-binutils.spec
@@ -45,16 +45,31 @@
Summary: A GNU collection of cross-compilation binary utilities
Name: %{cross}-binutils
-Version: 2.23.51.0.3
-Release: 2%{?dist}
+# Note - this version number is a lie. It should actually be 2.23.2 since
+# that is the version of the base sources. But we have decided to switch
+# from tracking the Linux Kernel binutils releases to tracking the FSF
+# binutils releases half way through the FSF binutils release cycle. The
+# version prior to this change was 2.23.52.0.1, but if we just set the new
+# version definition to be 2.23.2 then we would have a regression in the
+# binutils rpm numbers, which would break the rpm update mechanism. So
+# instead we create a bogus, higher, version number here. Once the next
+# official binutils release happens (2.24.0) we will be able to restore
+# Version to an honest value and everything will be good again.
+Version: 2.23.88.0.1
+%define srcdir binutils-2.23.2
+Release: 1%{?dist}
License: GPLv3+
Group: Development/Tools
URL: http://sources.redhat.com/binutils
-Source: ftp://ftp.kernel.org/pub/linux/devel/binutils/binutils-%{version}.tar.xz
-# The ftp.kernel.org/pub/linux/devel/binutils/ page is (temporarily) unavailable
-# so we use the GNU site instead.
-# Source: http://ftp.gnu.org/gnu/binutils/binutils-%{version}.tar.bz2
+# Note - see comment about the definition of Version above. Once Version is
+# restored to a proper value the definition of Source below should be changed
+# to use %{version} instead of 2.23.2
+#
+# Note - the Linux Kernel binutils releases are too unstable and contain too
+# many controversial patches so we stick with the official FSF version
+# instead.
+Source: http://ftp.gnu.org/gnu/binutils/binutils-2.23.2.tar.bz2
Source2: binutils-2.19.50.0.1-output-format.sed
Patch01: binutils-2.20.51.0.2-libtool-lib64.patch
Patch02: binutils-2.20.51.0.10-ppc64-pie.patch
@@ -69,8 +84,22 @@ Patch08: binutils-2.22.52.0.1-relro-on-by-default.patch
Patch09: binutils-2.22.52.0.1-export-demangle.h.patch
# Disable checks that config.h has been included before system headers. BZ #845084
Patch10: binutils-2.22.52.0.4-no-config-h-check.patch
-# Renames ARM LDRALT insn to LDALT. BZ# 869025
-Patch11: binutils-2.23.51.0.3-arm-ldralt.patch
+# Fix the creation of the index table in 64-bit thin archives.
+Patch11: binutils-2.23.52.0.1-64-bit-thin-archives.patch
+# Fix errors reported by version 5.0 of texinfo in gas documentation
+Patch12: binutils-2.23.52.0.1-as-doc-texinfo-fixes.patch
+# Fix addr2line to use the dynamic symbol table if it could not find any ordinary symbols.
+Patch13: binutils-2.23.52.0.1-addr2line-dynsymtab.patch
+# Check regular references without non-GOT references when building shared libraries.
+Patch14: binutils-2.23.52.0.1-check-regular-ifunc-refs.patch
+# Fix errors reported by version 5.0 of texinfo in ld documentation
+Patch15: binutils-2.23.2-ld-texinfo-fixes.patch
+Patch16: binutils-2.23.2-kernel-ld-r.patch
+Patch17: binutils-2.23.2-bfd-texinfo-fixes.patch
+# Add support for the alternate debug info files created by the DWZ program.
+Patch18: binutils-2.23.2-dwz-alt-debuginfo.patch
+# Correct bug introduced by patch 16
+Patch19: binutils-2.23.2-aarch64-em.patch
Buildroot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
BuildRequires: texinfo >= 4.0, gettext, flex, bison, zlib-devel
@@ -171,7 +200,6 @@ Cross-build binary image generation, manipulation and query tools. \
###############################################################################
%prep
-%define srcdir binutils-%{version}
%setup -q -n %{srcdir} -c
cd %{srcdir}
%patch01 -p0 -b .libtool-lib64~
@@ -190,7 +218,15 @@ cd %{srcdir}
%endif
%patch09 -p0 -b .export-demangle-h~
%patch10 -p0 -b .no-config-h-check~
-%patch11 -p0 -b .arm-ldralt~
+%patch11 -p0 -b .64bit-thin-archives~
+%patch12 -p0 -b .gas-texinfo~
+%patch13 -p0 -b .addr2line~
+%patch14 -p0 -b .check-ifunc~
+%patch15 -p0 -b .ld-texinfo~
+%patch16 -p0 -b .kernel-ld-r~
+%patch17 -p0 -b .bfd-texinfo~
+%patch18 -p0 -b .dwz~
+%patch19 -p0 -b .aarch64~
# We cannot run autotools as there is an exact requirement of autoconf-2.59.
@@ -629,6 +665,9 @@ rm -rf %{buildroot}
%do_files xtensa-linux-gnu %{build_xtensa}
%changelog
+* Tue Jun 4 2013 David Howells <dhowells@redhat.com> - 2.23.88.0.1-1
+- Update to binutils-2.22.88.0.1 to fix F19 texinfo issues [BZ 912921].
+
* Tue Jun 4 2013 David Howells <dhowells@redhat.com> - 2.23.51.0.3-2
- Backport cleanups from the RHEL-6.4 cross-compiler.
- Backport some macroisation from the RHEL-6.4 cross-compiler.