summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am19
1 files changed, 18 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 676b5cf4..95eec142 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -11,7 +11,9 @@ QUOTE := $(NULLSTRING)"# a double quote"
BUILDNUM := $(shell perl $(srcdir)/buildnum.pl)
NQBUILDNUM := $(subst \,,$(subst $(QUOTE),,$(BUILDNUM)))
DEBUG_DEFINES = @debug_defs@
-DS_DEFINES = -DBUILD_NUM=$(BUILDNUM) -DVENDOR="\"$(vendor)\"" -DBRAND="\"$(brand)\"" -DCAPBRAND="\"$(capbrand)\""
+# the -U undefines these symbols - should use the corresponding DS_ ones instead - see configure.ac
+DS_DEFINES = -DBUILD_NUM=$(BUILDNUM) -DVENDOR="\"$(vendor)\"" -DBRAND="\"$(brand)\"" -DCAPBRAND="\"$(capbrand)\"" \
+ -UPACKAGE_VERSION -UPACKAGE_TARNAME -UPACKAGE_STRING -UPACKAGE_BUGREPORT
DS_INCLUDES = -I$(srcdir)/ldap/include -I$(srcdir)/ldap/servers/slapd -I$(srcdir)/include -I.
# these paths are dependent on the settings of prefix and exec_prefix which may be specified
# at make time. So we cannot use AC_DEFINE in the configure.ac because that would set the
@@ -1367,3 +1369,18 @@ endif
if [ ! -d $(dir $@) ] ; then mkdir -p $(dir $@) ; fi
$(fixupcmd) $^ > $@
+# if distdir is a git tag, use that for the git archive tag, else
+# just assume a developer build and use HEAD
+git-archive:
+ if [ -n "$(SRCDISTDIR)" -a -d "$(SRCDISTDIR)" ] ; then \
+ srcdistdir=$(SRCDISTDIR) ; \
+ else \
+ srcdistdir=`pwd` ; \
+ fi ; \
+ cd $(srcdir) ; \
+ if git show-ref --tags -q $(distdir) ; then \
+ gittag=$(distdir) ; \
+ else \
+ gittag=HEAD ; \
+ fi ; \
+ git archive --prefix=$(distdir)/ $$gittag | bzip2 > $$srcdistdir/$(distdir).tar.bz2