summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorNoriko Hosoi <nhosoi@redhat.com>2008-05-16 17:34:23 +0000
committerNoriko Hosoi <nhosoi@redhat.com>2008-05-16 17:34:23 +0000
commit4a57eca0bf1a98153e8cdef1ea18b30fd80720b7 (patch)
tree4e794dd6478437bf105adb86c2aeeb21d7639ab7 /configure.ac
parentf4cadfcc40326a6ce29cb4b2aafee568fc15bb05 (diff)
downloadds-4a57eca0bf1a98153e8cdef1ea18b30fd80720b7.tar.gz
ds-4a57eca0bf1a98153e8cdef1ea18b30fd80720b7.tar.xz
ds-4a57eca0bf1a98153e8cdef1ea18b30fd80720b7.zip
Resolves: #436388
Summary: LDAPI: introduce --enable-autobind to support AUTOBIND Description: --enable-autobind is supported. Unless it's set, the auto-bind code is not compiled in.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5ef4ef5d..7acf9866 100644
--- a/configure.ac
+++ b/configure.ac
@@ -121,6 +121,21 @@ else
fi
AM_CONDITIONAL(enable_ldapi,test "$enable_ldapi" = "yes")
+if test -z "$enable_autobind" ; then
+ enable_autobind=no # if not set on cmdline, set default
+fi
+AC_MSG_CHECKING(for --enable-autobind)
+AC_ARG_ENABLE(autobind,
+ AS_HELP_STRING([--enable-autobind],
+ [enable auto bind over unix domain socket (LDAPI) support (default: no)]))
+if test "$enable_ldapi" = yes -a "$enable_autobind" = yes ; then
+ AC_MSG_RESULT(yes)
+ AC_DEFINE([ENABLE_AUTOBIND], [1], [enable ldapi auto bind support in the server])
+else
+ AC_MSG_RESULT(no)
+fi
+AM_CONDITIONAL(enable_autobind,test "$enable_autobind" = "yes")
+
if test -z "$enable_bitwise" ; then
enable_bitwise=yes # if not set on cmdline, set default
fi