summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRich Megginson <rmeggins@redhat.com>2007-05-16 19:45:26 +0000
committerRich Megginson <rmeggins@redhat.com>2007-05-16 19:45:26 +0000
commit1f0a9f9000e16b2bd66dc67b1848c4ef4af97c3a (patch)
tree5fe2e5b532bc0d792c4a95baa3779ac49c0c390b /configure.ac
parent6949bf2301e9f2fc5c64f6f9f60f7c24c0f7f68e (diff)
downloadds-1f0a9f9000e16b2bd66dc67b1848c4ef4af97c3a.tar.gz
ds-1f0a9f9000e16b2bd66dc67b1848c4ef4af97c3a.tar.xz
ds-1f0a9f9000e16b2bd66dc67b1848c4ef4af97c3a.zip
Resolves: bug 239764
Description: bitwise matching plugin Fix Description: Samba requires backend LDAP servers to support bitwise operations. This is to support search filters like this: (|(|(&(!(groupType:1.2.840.113556.1.4.803:=1))(groupType:1.2.840.113556.1.4.803:=2147483648)(groupType:1.2.840.113556.1.4.804:=10))(samAccountType=805306368))(samAccountType=805306369)) Note: This patch works for Samba's tests, but hasn't been more broadly or specifically tested. This commit also adds an --enable-bitwise option to configure (enabled by default - use --disable-bitwise to disable it) and adds the plugin entry to the configuration during new instance creation. Platforms tested: FC5/FC6
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d643656b..d0d48e44 100644
--- a/configure.ac
+++ b/configure.ac
@@ -121,6 +121,21 @@ else
fi
AM_CONDITIONAL(enable_ldapi,test "$enable_ldapi" = "yes")
+if test -z "$enable_bitwise" ; then
+ enable_bitwise=yes # if not set on cmdline, set default
+fi
+AC_MSG_CHECKING(for --enable-bitwise)
+AC_ARG_ENABLE(bitwise,
+ AS_HELP_STRING([--enable-bitwise],
+ [enable the bitwise matching rule plugin (default: yes)]))
+if test "$enable_bitwise" = yes ; then
+ AC_MSG_RESULT(yes)
+ AC_DEFINE([ENABLE_BITWISE], [1], [enable the bitwise plugin])
+else
+ AC_MSG_RESULT(no)
+fi
+AM_CONDITIONAL(enable_bitwise,test "$enable_bitwise" = "yes")
+
# the default prefix - override with --prefix or --with-fhs
AC_PREFIX_DEFAULT([/opt/$PACKAGE_NAME])