summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorNathan Kinder <nkinder@redhat.com>2007-04-26 02:37:54 +0000
committerNathan Kinder <nkinder@redhat.com>2007-04-26 02:37:54 +0000
commit88ddde4b61766e7ccfb45bc4f5e6a00f90bb992c (patch)
tree0c07364da2b1edfb38a603c3c6662c1429d2a2f0 /configure.ac
parentb0e077769e5247e96ef6fd66d75dc96698dda107 (diff)
downloadds-88ddde4b61766e7ccfb45bc4f5e6a00f90bb992c.tar.gz
ds-88ddde4b61766e7ccfb45bc4f5e6a00f90bb992c.tar.xz
ds-88ddde4b61766e7ccfb45bc4f5e6a00f90bb992c.zip
Resolves: 236612
Summary: Modified the with-fhs and with-fhs-opt configure options
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac45
1 files changed, 22 insertions, 23 deletions
diff --git a/configure.ac b/configure.ac
index 6913711a..d643656b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -131,41 +131,40 @@ m4_include(m4/fhs.m4)
# /etc, and /var. The with-fhs-opt option will use the
# prefix, but it's sysconfdir and localstatedir will be
# /etc/opt, and /var/opt.
-if test "$with_fhs" = "yes"; then
- ac_default_prefix=/usr
- prefix=$ac_default_prefix
- exec_prefix=$prefix
-dnl as opposed to the default /usr/etc
- sysconfdir='/etc'
-dnl as opposed to the default /usr/var
- localstatedir='/var'
+if test "$with_fhs_opt" = "yes"; then
+ # Override sysconfdir and localstatedir if FHS optional
+ # package was requested.
+ sysconfdir='/etc/opt'
+ localstatedir='/var/opt'
# relative to datadir
- sampledatadir=/$PACKAGE_NAME/data
+ sampledatadir=/data
# relative to datadir
- scripttemplatedir=/$PACKAGE_NAME/script-templates
+ scripttemplatedir=/script-templates
# relative to libdir
- serverdir=/$PACKAGE_NAME
+ serverdir=
# relative to libdir
- serverplugindir=/$PACKAGE_NAME/plugins
+ serverplugindir=/plugins
else
- if test "$with_fhs_opt" = "yes"; then
- # Override sysconfdir and localstatedir if FHS optional
- # package was requested.
- sysconfdir='/etc/opt'
- localstatedir='/var/opt'
+ if test "$with_fhs" = "yes"; then
+ ac_default_prefix=/usr
+ prefix=$ac_default_prefix
+ exec_prefix=$prefix
+ dnl as opposed to the default /usr/etc
+ sysconfdir='/etc'
+ dnl as opposed to the default /usr/var
+ localstatedir='/var'
fi
- # Paths for default layout
# relative to datadir
- sampledatadir=/data
+ sampledatadir=/$PACKAGE_NAME/data
# relative to datadir
- scripttemplatedir=/script-templates
+ scripttemplatedir=/$PACKAGE_NAME/script-templates
# relative to libdir
- serverdir=
+ serverdir=/$PACKAGE_NAME
# relative to libdir
- serverplugindir=/plugins
+ serverplugindir=/$PACKAGE_NAME/plugins
fi
-# Shared paths for both FHS and default layouts
+# Shared paths for all layouts
# relative to sysconfdir
configdir=/$PACKAGE_NAME/config
# relative to sysconfdir