summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorNoriko Hosoi <nhosoi@redhat.com>2008-10-23 22:42:55 +0000
committerNoriko Hosoi <nhosoi@redhat.com>2008-10-23 22:42:55 +0000
commit7572dfdc019f3e4b676d5a883d9fc0453dcde0e6 (patch)
treec33069f9583d1cb113efcaed5db1b722d5f7df3e /configure.ac
parentdc4d226a1a2f14d0f55e5e263ee5c1f989c7edab (diff)
downloadds-7572dfdc019f3e4b676d5a883d9fc0453dcde0e6.tar.gz
ds-7572dfdc019f3e4b676d5a883d9fc0453dcde0e6.tar.xz
ds-7572dfdc019f3e4b676d5a883d9fc0453dcde0e6.zip
Resolves: #468248
Summary: LDAPI: when nsslapd-ldapiautodnsuffix doesn't exist - Bind is incorrect Description: - introducing --enable-auto-dn-suffix option to configure (disabled by default) - building the auto-dn-suffix code only when the option is set
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 54d732d8..243b157b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -137,6 +137,21 @@ else
fi
AM_CONDITIONAL(enable_autobind,test "$enable_autobind" = "yes")
+if test -z "$enable_auto_dn_suffix" ; then
+ enable_auto_dn_suffix=no # if not set on cmdline, set default
+fi
+AC_MSG_CHECKING(for --enable-auto-dn-suffix)
+AC_ARG_ENABLE(autobind,
+ AS_HELP_STRING([--enable-auto-dn-suffix],
+ [enable auto bind with auto dn suffix over unix domain socket (LDAPI) support (default: no)]))
+if test "$enable_ldapi" = yes -a "$enable_autobind" = yes -a "$enable_auto_dn_suffix" = "yes"; then
+ AC_MSG_RESULT(yes)
+ AC_DEFINE([ENABLE_AUTO_DN_SUFFIX], [1], [enable ldapi auto bind with auto dn suffix support in the server])
+else
+ AC_MSG_RESULT(no)
+fi
+AM_CONDITIONAL(enable_auto_dn_suffix,test "$enable_auto_dn_suffix" = "yes")
+
if test -z "$enable_bitwise" ; then
enable_bitwise=yes # if not set on cmdline, set default
fi