summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorNathan Kinder <nkinder@redhat.com>2009-05-11 10:23:34 -0700
committerNathan Kinder <nkinder@redhat.com>2009-05-11 10:23:34 -0700
commit75dbea2bc03a224900292dea1701f1b305f3fa06 (patch)
tree6ff7104f60692a34db295f7e2758bfcaec887eb5 /Makefile.am
parentd19eafcd211d89cffdac1b2c3432087443e7d122 (diff)
downloadds-75dbea2bc03a224900292dea1701f1b305f3fa06.tar.gz
ds-75dbea2bc03a224900292dea1701f1b305f3fa06.tar.xz
ds-75dbea2bc03a224900292dea1701f1b305f3fa06.zip
Generated autotools files for syntax validation feature.
A change was also made to Makefile.am to avoid library versioning for our C++ plug-in libraries. This change should allow us to use autogen.sh on recent platforms without running into issues during build-time.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index b9cdc180..8a6139e1 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -646,7 +646,7 @@ libacl_plugin_la_SOURCES = ldap/servers/plugins/acl/acl.c \
libacl_plugin_la_CPPFLAGS = -I$(srcdir)/include/libaccess $(PLUGIN_CPPFLAGS)
libacl_plugin_la_LIBADD = libns-dshttpd.la $(LIBCSTD) $(LIBCRUN)
libacl_plugin_la_LDFLAGS = -avoid-version
-libacl_plugin_la_LINK = $(CXXLINK)
+libacl_plugin_la_LINK = $(CXXLINK) -avoid-version
#------------------------
# libattr-unique-plugin
@@ -735,7 +735,7 @@ libcollation_plugin_la_SOURCES = ldap/servers/plugins/collation/collate.c \
libcollation_plugin_la_CPPFLAGS = @icu_inc@ $(PLUGIN_CPPFLAGS)
libcollation_plugin_la_LIBADD = $(ICU_LINK) $(LIBCSTD) $(LIBCRUN)
libcollation_plugin_la_LDFLAGS = -avoid-version
-libcollation_plugin_la_LINK = $(CXXLINK)
+libcollation_plugin_la_LINK = $(CXXLINK) -avoid-version
#------------------------
# libmemberof-plugin