summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRich Megginson <rmeggins@redhat.com>2007-02-19 23:55:04 +0000
committerRich Megginson <rmeggins@redhat.com>2007-02-19 23:55:04 +0000
commit6ea6bd03b9d95fdc3f34a6892eb9d7bff580324f (patch)
tree1d8930b5a69d6b781f573a8b33aa8fea28185591 /Makefile.am
parent47d5f680b42c229bdeef0be7fe8a046a7443a41b (diff)
downloadds-6ea6bd03b9d95fdc3f34a6892eb9d7bff580324f.tar.gz
ds-6ea6bd03b9d95fdc3f34a6892eb9d7bff580324f.tar.xz
ds-6ea6bd03b9d95fdc3f34a6892eb9d7bff580324f.zip
Resolves: bug 229286
Bug Description: Solaris build: link shared libs correctly with libtool Reviewed by: nkinder, prowley (Thanks!) Fix Description: We have to use the $(CXXLINK) Makefile macro to build shared libs that use C++ code or link with C++ libs. In addition, Sun C++ link needs -lCstd and -lCrun. I added AC_DISABLE_STATIC so that we wouldn't generate all the .a libs we don't use. Lastly, but not leastly, libtool on rhel/fedora has a "feature" that adds several gcc-isms to the libtool script generated by configure. At best, these cause builds with non-gcc compilers to complain quite a bit, and at worst, cause the build to fail. I've added a sed command in configure to remove these gcc-isms from libtool on non-gcc platforms. Platforms tested: RHEL4, FC6, Solaris 9 Flag Day: no Doc impact: no
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index a16198e9..75e8ffbd 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -46,6 +46,8 @@ PAM_LINK = -lpam
LIBSOCKET=@LIBSOCKET@
LIBNSL=@LIBNSL@
LIBDL=@LIBDL@
+LIBCSTD=@LIBCSTD@
+LIBCRUN=@LIBCRUN@
#------------------------
# Generated Sources
@@ -495,8 +497,9 @@ libacl_plugin_la_SOURCES = ldap/servers/plugins/acl/acl.c \
ldap/servers/plugins/acl/aclutil.c
libacl_plugin_la_CPPFLAGS = -I$(srcdir)/include/libaccess $(PLUGIN_CPPFLAGS)
-libacl_plugin_la_LIBADD = libns-dshttpd.la
+libacl_plugin_la_LIBADD = libns-dshttpd.la $(LIBCSTD) $(LIBCRUN)
libacl_plugin_la_LDFLAGS = -avoid-version
+libacl_plugin_la_LINK = $(CXXLINK)
#------------------------
# libattr-unique-plugin
@@ -583,8 +586,9 @@ libcollation_plugin_la_SOURCES = ldap/servers/plugins/collation/collate.c \
ldap/servers/plugins/collation/orfilter.c
libcollation_plugin_la_CPPFLAGS = @icu_inc@ $(PLUGIN_CPPFLAGS)
-libcollation_plugin_la_LIBADD = $(ICU_LINK)
+libcollation_plugin_la_LIBADD = $(ICU_LINK) $(LIBCSTD) $(LIBCRUN)
libcollation_plugin_la_LDFLAGS = -avoid-version
+libcollation_plugin_la_LINK = $(CXXLINK)
#------------------------
# libpam-passthru-plugin