summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRich Megginson <rmeggins@redhat.com>2007-06-08 20:36:53 +0000
committerRich Megginson <rmeggins@redhat.com>2007-06-08 20:36:53 +0000
commitd9b8787008e72e696b2b92f20e18b4c3f5f0a38c (patch)
tree3fc399b0047f15c994515c4a5e3470512f747c25 /Makefile.am
parent7f686305a98a4289f4ebb3f62441523950352280 (diff)
downloadds-d9b8787008e72e696b2b92f20e18b4c3f5f0a38c.tar.gz
ds-d9b8787008e72e696b2b92f20e18b4c3f5f0a38c.tar.xz
ds-d9b8787008e72e696b2b92f20e18b4c3f5f0a38c.zip
Resolves: bug 237356
Description: Move DS Admin Code into Admin Server Fix Description: The Resource class needs to support more than 1 resource file e.g. for ds-base and ds-admin. The property dir should be under $datadir. Property files are data files, not really config files. Added a shared_lib_suffix token Fixed some wording errors in the resource file. Platforms tested: RHEL4 Flag Day: no Doc impact: No new doc impact from previous commits for this bug.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 7 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index d4fe8f9a..8bebecd9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -67,7 +67,7 @@ dberrstrs.h: Makefile
#------------------------
configdir = $(sysconfdir)@configdir@
sampledatadir = $(datadir)@sampledatadir@
-propertydir = $(sysconfdir)@propertydir@
+propertydir = $(datadir)@propertydir@
schemadir = $(sysconfdir)@schemadir@
serverdir = $(libdir)@serverdir@
serverplugindir = $(libdir)@serverplugindir@
@@ -76,6 +76,8 @@ initdir = $(sysconfdir)@initdir@
instconfigdir = @instconfigdir@
perldir = $(libdir)@perldir@
+shared_lib_suffix = @shared_lib_suffix@
+
#------------------------
# Build Products
#------------------------
@@ -1016,7 +1018,8 @@ fixupcmd = sed \
-e 's,@brand\@,$(brand),g' \
-e 's,@capbrand\@,$(capbrand),g' \
-e 's,@PACKAGE_VERSION\@,$(PACKAGE_VERSION),g' \
- -e 's,@perldir\@,$(perldir),g'
+ -e 's,@perldir\@,$(perldir),g' \
+ -e 's,@shared_lib_suffix\@,$(shared_lib_suffix),g'
else
fixupcmd = sed \
-e 's,@bindir\@,$(bindir),g' \
@@ -1046,7 +1049,8 @@ fixupcmd = sed \
-e 's,@brand\@,$(brand),g' \
-e 's,@capbrand\@,$(capbrand),g' \
-e 's,@PACKAGE_VERSION\@,$(PACKAGE_VERSION),g' \
- -e 's,@perldir\@,$(perldir),g'
+ -e 's,@perldir\@,$(perldir),g' \
+ -e 's,@shared_lib_suffix\@,$(shared_lib_suffix),g'
endif
%: %.in