summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRich Megginson <rmeggins@redhat.com>2007-08-02 14:39:01 +0000
committerRich Megginson <rmeggins@redhat.com>2007-08-02 14:39:01 +0000
commitd7531c68d34d83c17c0d1996fec6d6a0ebfc0e4b (patch)
treed9dc41736d47540967b5523a96d6a0eed9f6b379 /Makefile.am
parent2ebeaf1fbbba60e8ed0040bb904c1bb858a876c3 (diff)
downloadds-d7531c68d34d83c17c0d1996fec6d6a0ebfc0e4b.tar.gz
ds-d7531c68d34d83c17c0d1996fec6d6a0ebfc0e4b.tar.xz
ds-d7531c68d34d83c17c0d1996fec6d6a0ebfc0e4b.zip
Resolves: bug 250535
Bug Description: improve perldap script execution ability on bundled platforms Reviewed by: nkinder (Thanks!) Fix Description: Most platforms will just use perl from PATH. However, on Solaris and HP-UX, we have to use special 64 bit versions to execute perldap, since perldap is 64 bit on those platforms. Also, if bundling all of the dependent components into the single package, we need to make sure the perl library path is set correctly to find perldap. The last step will be to build our version of perldap on the bundled platforms to use rpath to point to the correct runtime library location. Platforms tested: RHEL4, HP-UX 11.23 IPF 64 bit Flag Day: no Doc impact: no
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 9 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 4ea75be7..879d60c1 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -989,6 +989,9 @@ rsearch_bin_LDADD = $(NSPR_LINK) $(NSS_LINK) $(LDAPSDK_LINK) $(SASL_LINK) $(LIBS
# i.e. it literally copies in '${prefix}' rather than expanding it out - we want this instead:
# LD_LIBRARY_PATH = /usr/lib/fedora-ds
if BUNDLE
+# on the systems on which we bundle, perldap will be in libdir/perl, so we need to point
+# the perlpath there - on other systems, perldap will be installed as a site module into
+# the system perl
fixupcmd = sed \
-e 's,@bindir\@,$(bindir),g' \
-e 's,@sbindir\@,$(sbindir),g' \
@@ -1029,10 +1032,11 @@ fixupcmd = sed \
-e 's,@PACKAGE_BASE_VERSION\@,$(PACKAGE_BASE_VERSION),g' \
-e 's,@BUILDNUM\@,$(BUILDNUM),g' \
-e 's,@NQBUILD_NUM\@,$(NQBUILDNUM),g' \
- -e 's,@perldir\@,$(perldir),g' \
+ -e 's,@perlpath\@,$(perldir) $(libdir)/perl/arch $(libdir)/perl,g' \
-e 's,@defaultuser\@,$(defaultuser),g' \
-e 's,@defaultgroup\@,$(defaultgroup),g' \
- -e 's,@with_fhs_opt\@,@with_fhs_opt@,g'
+ -e 's,@with_fhs_opt\@,@with_fhs_opt@,g' \
+ -e 's,@perlexec\@,@perlexec@,g'
else
fixupcmd = sed \
-e 's,@bindir\@,$(bindir),g' \
@@ -1074,10 +1078,11 @@ fixupcmd = sed \
-e 's,@PACKAGE_BASE_VERSION\@,$(PACKAGE_BASE_VERSION),g' \
-e 's,@BUILDNUM\@,$(BUILDNUM),g' \
-e 's,@NQBUILD_NUM\@,$(NQBUILDNUM),g' \
- -e 's,@perldir\@,$(perldir),g' \
+ -e 's,@perlpath\@,$(perldir),g' \
-e 's,@defaultuser\@,$(defaultuser),g' \
-e 's,@defaultgroup\@,$(defaultgroup),g' \
- -e 's,@with_fhs_opt\@,@with_fhs_opt@,g'
+ -e 's,@with_fhs_opt\@,@with_fhs_opt@,g' \
+ -e 's,@perlexec\@,@perlexec@,g'
endif
%: %.in