summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRich Megginson <rmeggins@redhat.com>2007-07-04 01:28:17 +0000
committerRich Megginson <rmeggins@redhat.com>2007-07-04 01:28:17 +0000
commitaf10ba6ae36a6f50ff55be43da77fac0c38542a5 (patch)
tree9f490a8d72ebcac9e84e2bfd394fedd59c3f996c /Makefile.am
parent24b026971adfd97c4ff542aa56211250b54abc97 (diff)
downloadds-af10ba6ae36a6f50ff55be43da77fac0c38542a5.tar.gz
ds-af10ba6ae36a6f50ff55be43da77fac0c38542a5.tar.xz
ds-af10ba6ae36a6f50ff55be43da77fac0c38542a5.zip
Resolves: bug 246683
Bug Description: Reimplement ds_create without setuputil code Reviewed by: nhosoi (Thanks!) Fix Description: ds_create was a CGI program that would create a new instance, set it up to be managed by console, and register it with the config ds. The new ds_create CGI perl script does just that. One tricky part was that, rather than enabling the pass through auth plugin and having to restart the server, the new server is created without being started, then the modification is done to the new server dse.ldif file directly, using the new FileConn.pm module, which simulates a Mozilla::LDAP::Conn on an LDIF file. This also allows us to create a new instance with a pre-hashed rootdn password, rather than having to send the cleartext password. I had to move around some code in AdminServer and AdminUtil so that I could use it from ds_create. I also implemented support for the admin server PASSWORD_PIPE in perl so we could use it in other CGI perl scripts. Finally, the error handling was not consistent in our code, so I made explicit the passing of error messages up and down the stack. Oh how I wish we could just do this in python and use exception handling . . . I added a test for ds_create. Platforms tested: RHEL4 Flag Day: Yes - autotool changes Doc impact: No. Should work the same way as the old ds_create.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index ea116701..236041a3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -200,7 +200,8 @@ perl_SCRIPTS = ldap/admin/src/scripts/SetupLog.pm \
ldap/admin/src/scripts/DSDialogs.pm \
ldap/admin/src/scripts/Setup.pm \
ldap/admin/src/scripts/Migration.pm \
- ldap/admin/src/scripts/DSMigration.pm
+ ldap/admin/src/scripts/DSMigration.pm \
+ ldap/admin/src/scripts/FileConn.pm
property_DATA = ldap/admin/src/scripts/setup-ds.res \
ldap/admin/src/scripts/migrate-ds.res