summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRich Megginson <rmeggins@redhat.com>2007-06-29 21:12:22 +0000
committerRich Megginson <rmeggins@redhat.com>2007-06-29 21:12:22 +0000
commitad85c482b235c603bd29da7d754415065400bdf1 (patch)
treeb300f61426dccbe71e8e83a6567d42026089cd6c /Makefile.am
parentda39f866049f4416691e77c1aa71a1643fdccbf9 (diff)
downloadds-ad85c482b235c603bd29da7d754415065400bdf1.tar.gz
ds-ad85c482b235c603bd29da7d754415065400bdf1.tar.xz
ds-ad85c482b235c603bd29da7d754415065400bdf1.zip
Resolves: bug 245815
Description: DS Admin Migration framework Reviewed by: nhosoi (Thanks!) Fix Description: Created a Migration class that is very similar to the Setup class - to act as a sort of global context for the migration process. Moved most of the guts of migrateTo11 into the new DSMigration class and the new migrate-ds.pl - we should deprecate migrateTo11 in favor of migrate-ds.pl. I had to enhance the check_and_add_entry function to handle pseudo-LDIF change records - pseudo because mozilla perldap LDIF has no real LDIF change record support. Fixed a bug in create_instance.c - creating an instance without starting it was not working if the port number of an existing directory server was supplied. Added a new method createDSInstance to Util - this just wraps ds_newinst.pl for now. Platforms tested: RHEL4 Doc: Yes. We will need to document the migration procedures. Flag day: Yes. Autotool file changes.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 7 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 37ae67af..ea116701 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -186,7 +186,8 @@ bin_SCRIPTS = $(srcdir)/ldap/servers/slapd/tools/rsearch/scripts/dbgen.pl \
ldap/admin/src/scripts/cl-dump.pl \
wrappers/repl-monitor \
ldap/admin/src/scripts/repl-monitor.pl \
- ldap/admin/src/scripts/setup-ds.pl
+ ldap/admin/src/scripts/setup-ds.pl \
+ ldap/admin/src/scripts/migrate-ds.pl
perl_SCRIPTS = ldap/admin/src/scripts/SetupLog.pm \
ldap/admin/src/scripts/Resource.pm \
@@ -197,9 +198,12 @@ perl_SCRIPTS = ldap/admin/src/scripts/SetupLog.pm \
ldap/admin/src/scripts/DialogManager.pm \
ldap/admin/src/scripts/Dialog.pm \
ldap/admin/src/scripts/DSDialogs.pm \
- ldap/admin/src/scripts/Setup.pm
+ ldap/admin/src/scripts/Setup.pm \
+ ldap/admin/src/scripts/Migration.pm \
+ ldap/admin/src/scripts/DSMigration.pm
-property_DATA = ldap/admin/src/scripts/setup-ds.res
+property_DATA = ldap/admin/src/scripts/setup-ds.res \
+ ldap/admin/src/scripts/migrate-ds.res
task_SCRIPTS = ldap/admin/src/scripts/template-bak2db \
ldap/admin/src/scripts/template-db2bak \