summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorNoriko Hosoi <nhosoi@redhat.com>2007-06-15 17:02:29 +0000
committerNoriko Hosoi <nhosoi@redhat.com>2007-06-15 17:02:29 +0000
commit9a9b03fcc2c1afcc270aeb450346533dbd6c594a (patch)
tree4eedb0655c1cd24ec79e346a85953617a59f2f9a /Makefile.am
parentad1a3df37851e131e3570cb98d884b3e01fa89ad (diff)
downloadds-9a9b03fcc2c1afcc270aeb450346533dbd6c594a.tar.gz
ds-9a9b03fcc2c1afcc270aeb450346533dbd6c594a.tar.xz
ds-9a9b03fcc2c1afcc270aeb450346533dbd6c594a.zip
Resolves: 237356
Summary: Move DS Admin Code into Admin Server (Comment #62) Description: providing slapd.inf having the DS static info for the setup/config
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 3f0baf49..0f4027cd 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -75,6 +75,7 @@ taskdir = $(datadir)@scripttemplatedir@
initdir = $(sysconfdir)@initdir@
instconfigdir = @instconfigdir@
perldir = $(libdir)@perldir@
+infdir = $(datadir)@infdir@
shared_lib_suffix = @shared_lib_suffix@
@@ -106,7 +107,7 @@ serverplugin_LTLIBRARIES = libacl-plugin.la libattr-unique-plugin.la \
libpassthru-plugin.la libpresence-plugin.la \
libpwdstorage-plugin.la libreferint-plugin.la libreplication-plugin.la \
libretrocl-plugin.la libroles-plugin.la libstatechange-plugin.la libsyntax-plugin.la \
- libviews-plugin.la $(LIBPAM_PASSTHRU_PLUGIN) $(LIBDNA_PLUGIN) $(LIBBITWISE_PLUGIN)
+ libviews-plugin.la $(LIBPAM_PASSTHRU_PLUGIN) $(LIBDNA_PLUGIN) $(LIBBITWISE_PLUGIN)
nodist_property_DATA = ns-slapd.properties
@@ -216,6 +217,8 @@ task_SCRIPTS = ldap/admin/src/scripts/template-bak2db \
init_SCRIPTS = wrappers/$(PACKAGE_NAME)
+inf_DATA = ldap/cm/newinst/slapd.inf
+
#////////////////////////////////////////////////////////////////
#
# Server Strings
@@ -1018,7 +1021,9 @@ fixupcmd = sed \
-e 's,@ECHO_C\@,$(ECHO_C),g' \
-e 's,@brand\@,$(brand),g' \
-e 's,@capbrand\@,$(capbrand),g' \
+ -e 's,@vendor\@,$(vendor),g' \
-e 's,@PACKAGE_VERSION\@,$(PACKAGE_VERSION),g' \
+ -e 's,@BUILDNUM\@,$(BUILDNUM),g' \
-e 's,@perldir\@,$(perldir),g' \
-e 's,@shared_lib_suffix\@,$(shared_lib_suffix),g'
else
@@ -1049,7 +1054,9 @@ fixupcmd = sed \
-e 's,@ECHO_C\@,$(ECHO_C),g' \
-e 's,@brand\@,$(brand),g' \
-e 's,@capbrand\@,$(capbrand),g' \
+ -e 's,@vendor\@,$(vendor),g' \
-e 's,@PACKAGE_VERSION\@,$(PACKAGE_VERSION),g' \
+ -e 's,@BUILDNUM\@,$(BUILDNUM),g' \
-e 's,@perldir\@,$(perldir),g' \
-e 's,@shared_lib_suffix\@,$(shared_lib_suffix),g'
endif