summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRich Megginson <rmeggins@redhat.com>2007-06-08 01:09:16 +0000
committerRich Megginson <rmeggins@redhat.com>2007-06-08 01:09:16 +0000
commit7f686305a98a4289f4ebb3f62441523950352280 (patch)
tree62e376a4c3bd83d7ef18823d00f0b55cca9bc411 /Makefile.am
parent6fbde87fb096a7919796c9568463a0411bb80b1e (diff)
downloadds-7f686305a98a4289f4ebb3f62441523950352280.tar.gz
ds-7f686305a98a4289f4ebb3f62441523950352280.tar.xz
ds-7f686305a98a4289f4ebb3f62441523950352280.zip
Resolves: bug 237356
Description: Move DS Admin Code into Admin Server Fix Description: This adds the setup related perl modules, scripts, and resource files to the DS base code. This will allow a user to interactively setup (create an instance of) a directory server. This will also form the base of the work to add the console and admin server related setup code. New files/directories: $libdir/fedora-ds/perl - this is where the perl modules (Setup.pm, etc.) will be installed. $bindir/setup-ds.pl - the script to use to interactively create an instance of directory server. This has use lib '$libdir/fedora-ds/perl' hard coded into it at build time, in order to find the "private" setup perl modules. If you invoke this script in silent mode (setup-ds.pl -s) then it is exactly the same as just using ds_newinst.pl. $sysconfdir/fedora-ds/property/setup-ds.res - Resources for setup-ds.pl and the associated modules. I also fixed a problem with the libns-dshttpd linkage. Platforms tested: RHEL4 Flag Day: no Doc impact: Yes. All of these new items will need to be documented.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am31
1 files changed, 27 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 613dac9d..d4fe8f9a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -74,6 +74,7 @@ serverplugindir = $(libdir)@serverplugindir@
taskdir = $(datadir)@scripttemplatedir@
initdir = $(sysconfdir)@initdir@
instconfigdir = @instconfigdir@
+perldir = $(libdir)@perldir@
#------------------------
# Build Products
@@ -167,7 +168,21 @@ bin_SCRIPTS = $(srcdir)/ldap/servers/slapd/tools/rsearch/scripts/dbgen.pl \
wrappers/cl-dump \
ldap/admin/src/scripts/cl-dump.pl \
wrappers/repl-monitor \
- ldap/admin/src/scripts/repl-monitor.pl
+ ldap/admin/src/scripts/repl-monitor.pl \
+ ldap/admin/src/scripts/setup-ds.pl
+
+perl_SCRIPTS = ldap/admin/src/scripts/SetupLog.pm \
+ ldap/admin/src/scripts/Resource.pm \
+ ldap/admin/src/scripts/Util.pm \
+ ldap/admin/src/scripts/Setup.pm \
+ ldap/admin/src/scripts/SetupDialogs.pm \
+ ldap/admin/src/scripts/Inf.pm \
+ ldap/admin/src/scripts/DialogManager.pm \
+ ldap/admin/src/scripts/Dialog.pm \
+ ldap/admin/src/scripts/DSDialogs.pm \
+ ldap/admin/src/scripts/Setup.pm
+
+property_DATA = ldap/admin/src/scripts/setup-ds.res
task_SCRIPTS = ldap/admin/src/scripts/template-bak2db \
ldap/admin/src/scripts/template-db2bak \
@@ -327,7 +342,7 @@ libns_dshttpd_la_SOURCES = lib/libaccess/access_plhash.cpp \
$(libldaputil_a_SOURCES)
libns_dshttpd_la_CPPFLAGS = -I$(srcdir)/include/base $(AM_CPPFLAGS) -I$(srcdir)/lib/ldaputil @ldapsdk_inc@ @nss_inc@ @nspr_inc@
-libns_dshttpd_la_LIBADD = $(LDAPSDK_LINK) $(NSS_LINK) $(NSPR_LINK)
+libns_dshttpd_la_LIBADD = $(LDAPSDK_LINK) $(SASL_LINK) $(NSS_LINK) $(NSPR_LINK)
#------------------------
# libslapd
@@ -997,7 +1012,11 @@ fixupcmd = sed \
-e 's,@package_name\@,$(PACKAGE_NAME),g' \
-e 's,@instconfigdir\@,$(instconfigdir),g' \
-e 's,@ECHO_N\@,$(ECHO_N),g' \
- -e 's,@ECHO_C\@,$(ECHO_C),g'
+ -e 's,@ECHO_C\@,$(ECHO_C),g' \
+ -e 's,@brand\@,$(brand),g' \
+ -e 's,@capbrand\@,$(capbrand),g' \
+ -e 's,@PACKAGE_VERSION\@,$(PACKAGE_VERSION),g' \
+ -e 's,@perldir\@,$(perldir),g'
else
fixupcmd = sed \
-e 's,@bindir\@,$(bindir),g' \
@@ -1023,7 +1042,11 @@ fixupcmd = sed \
-e 's,@package_name\@,$(PACKAGE_NAME),g' \
-e 's,@instconfigdir\@,$(instconfigdir),g' \
-e 's,@ECHO_N\@,$(ECHO_N),g' \
- -e 's,@ECHO_C\@,$(ECHO_C),g'
+ -e 's,@ECHO_C\@,$(ECHO_C),g' \
+ -e 's,@brand\@,$(brand),g' \
+ -e 's,@capbrand\@,$(capbrand),g' \
+ -e 's,@PACKAGE_VERSION\@,$(PACKAGE_VERSION),g' \
+ -e 's,@perldir\@,$(perldir),g'
endif
%: %.in