summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRich Megginson <rmeggins@redhat.com>2007-05-16 19:45:26 +0000
committerRich Megginson <rmeggins@redhat.com>2007-05-16 19:45:26 +0000
commit1f0a9f9000e16b2bd66dc67b1848c4ef4af97c3a (patch)
tree5fe2e5b532bc0d792c4a95baa3779ac49c0c390b /Makefile.am
parent6949bf2301e9f2fc5c64f6f9f60f7c24c0f7f68e (diff)
downloadds-1f0a9f9000e16b2bd66dc67b1848c4ef4af97c3a.tar.gz
ds-1f0a9f9000e16b2bd66dc67b1848c4ef4af97c3a.tar.xz
ds-1f0a9f9000e16b2bd66dc67b1848c4ef4af97c3a.zip
Resolves: bug 239764
Description: bitwise matching plugin Fix Description: Samba requires backend LDAP servers to support bitwise operations. This is to support search filters like this: (|(|(&(!(groupType:1.2.840.113556.1.4.803:=1))(groupType:1.2.840.113556.1.4.803:=2147483648)(groupType:1.2.840.113556.1.4.804:=10))(samAccountType=805306368))(samAccountType=805306369)) Note: This patch works for Samba's tests, but hasn't been more broadly or specifically tested. This commit also adds an --enable-bitwise option to configure (enabled by default - use --disable-bitwise to disable it) and adds the plugin entry to the configuration during new instance creation. Platforms tested: FC5/FC6
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am15
1 files changed, 14 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 57fc66b3..613dac9d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -93,13 +93,17 @@ if enable_dna
LIBDNA_PLUGIN = libdna-plugin.la
endif
+if enable_bitwise
+LIBBITWISE_PLUGIN = libbitwise-plugin.la
+endif
+
serverplugin_LTLIBRARIES = libacl-plugin.la libattr-unique-plugin.la \
libback-ldbm.la libchainingdb-plugin.la libcos-plugin.la libdes-plugin.la \
libdistrib-plugin.la libhttp-client-plugin.la libcollation-plugin.la \
libpassthru-plugin.la libpresence-plugin.la \
libpwdstorage-plugin.la libreferint-plugin.la libreplication-plugin.la \
libretrocl-plugin.la libroles-plugin.la libstatechange-plugin.la libsyntax-plugin.la \
- libviews-plugin.la $(LIBPAM_PASSTHRU_PLUGIN) $(LIBDNA_PLUGIN)
+ libviews-plugin.la $(LIBPAM_PASSTHRU_PLUGIN) $(LIBDNA_PLUGIN) $(LIBBITWISE_PLUGIN)
nodist_property_DATA = ns-slapd.properties
@@ -323,6 +327,7 @@ libns_dshttpd_la_SOURCES = lib/libaccess/access_plhash.cpp \
$(libldaputil_a_SOURCES)
libns_dshttpd_la_CPPFLAGS = -I$(srcdir)/include/base $(AM_CPPFLAGS) -I$(srcdir)/lib/ldaputil @ldapsdk_inc@ @nss_inc@ @nspr_inc@
+libns_dshttpd_la_LIBADD = $(LDAPSDK_LINK) $(NSS_LINK) $(NSPR_LINK)
#------------------------
# libslapd
@@ -783,6 +788,14 @@ libdna_plugin_la_SOURCES = ldap/servers/plugins/dna/dna.c
libdna_plugin_la_CPPFLAGS = $(PLUGIN_CPPFLAGS)
libdna_plugin_la_LDFLAGS = -avoid-version
+#------------------------
+# libbitwise-plugin
+#------------------------
+libbitwise_plugin_la_SOURCES = ldap/servers/plugins/bitwise/bitwise.c
+
+libbitwise_plugin_la_CPPFLAGS = $(PLUGIN_CPPFLAGS)
+libbitwise_plugin_la_LDFLAGS = -avoid-version
+
#////////////////////////////////////////////////////////////////
#