summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRich Megginson <rmeggins@redhat.com>2007-01-12 16:18:15 +0000
committerRich Megginson <rmeggins@redhat.com>2007-01-12 16:18:15 +0000
commitfd287c66734fc7add132e4685fd0250ce2605eb0 (patch)
treeac13e7ef739cebe725b1b2d341136587cd72e503 /Makefile.am
parent38c192bb2279e1a099b1ec1b6e8eeea24b3fca58 (diff)
downloadds-fd287c66734fc7add132e4685fd0250ce2605eb0.tar.gz
ds-fd287c66734fc7add132e4685fd0250ce2605eb0.tar.xz
ds-fd287c66734fc7add132e4685fd0250ce2605eb0.zip
Resolves: bug 222398
Bug Description: Allow building on Fedora Reviewed by: nhosoi (Thanks!) Fix Description: There are a few issues with building on Fedora (5 or later): 1) Need to be able to build with db4.2, db4.3, db4.4, etc. This version auto-detects the db version from the db.h file it finds. In order to use a different db version, just use configure --with-db=path or --with-db-inc=path that points to a different db.h 2) mozldap and svrcore are now part of Fedora, so we need to look for those components. Look for mozldap6 first to allow building on RHEL-4 as well. mozldap now includes libldif, so add that to the link line. svrcore-devel is now just svrcore - a svrcore runtime package and a svrcore-devel build time package. 3) FHS means FHS - /etc, /var/, prefix=/usr and exec_prefix=/usr. It doesn't make any sense to talk about FHS under a prefix. This means the default build will do /opt/fedora-ds/etc, var, lib, bin, share, and so on instead of /opt/fedora-ds/usr/etc. --with-fhs resets prefix=/usr and exec_prefix=/usr, and overrides the default settings for sysconfdir and localstatedir So, different build types: FHS - use configure --with-fhs - uses /etc, /var, /usr/lib, /usr/share, etc. Nothing - configure - uses /opt/fedora-ds/etc/, var/, bin/, lib/, etc. GNU style - configure --prefix=/usr/local - /usr/local/etc, /usr/local/bin, /usr/local/var, and so on Developers can use configure --prefix=/home/user/fds && make && make install to install local versions Platforms tested: FC-6 Flag Day: no Doc impact: no
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 83385b83..4de0cfdf 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -30,8 +30,8 @@ PLUGIN_CPPFLAGS = $(AM_CPPFLAGS) @ldapsdk_inc@ @nss_inc@ @nspr_inc@
#------------------------
NSPR_LINK = @nspr_lib@ -lplc4 -lplds4 -lnspr4
NSS_LINK = @nss_lib@ -lssl3 -lnss3 -lsoftokn3
-LDAPSDK_LINK = @ldapsdk_lib@ -lssldap60 -lldap60 -lprldap60 -lldif60
-DB_LINK = @db_lib@ -ldb-4.2
+LDAPSDK_LINK = @ldapsdk_lib@ -lssldap60 -lprldap60 -lldap60 -lldif60
+DB_LINK = @db_lib@ -ldb-@db_libver@
SASL_LINK = @sasl_lib@ -lsasl2
SVRCORE_LINK = @svrcore_lib@ -lsvrcore
ICU_LINK = @icu_lib@ -licui18n -licuuc -licudata