summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorNathan Kinder <nkinder@triton.usersys.redhat.com>2009-07-14 14:25:05 -0700
committerNathan Kinder <nkinder@triton.usersys.redhat.com>2009-07-14 14:25:05 -0700
commit3276d926e61eac681c48172d1780a4650253254d (patch)
tree5122436391503f54c034d9488abb19e199dd2fa0 /Makefile.am
parentbea97a2d7b6437419cc5649645f0c58b6966a46e (diff)
downloadds-3276d926e61eac681c48172d1780a4650253254d.tar.gz
ds-3276d926e61eac681c48172d1780a4650253254d.tar.xz
ds-3276d926e61eac681c48172d1780a4650253254d.zip
Add additional standard syntaxes.
This adds support for the following standard syntaxes, complete with validation functions: Bit String Delivery Method Enhanced Guide Facsimile Telephone Number Fax Guide Name And Optional UID Printable String Teletex Terminal Identifier Telex Number This patch does not change the schema to use any of these syntaxes yet. That will come when we update to the current versions of the standard schema from the LDAP RFCs. I also fixed an error in makefile.am where Setup.pm was listed twice in perl_DATA.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index dd7965fc..65977d9d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -277,7 +277,6 @@ perl_DATA = ldap/admin/src/scripts/SetupLog.pm \
ldap/admin/src/scripts/DialogManager.pm \
ldap/admin/src/scripts/Dialog.pm \
ldap/admin/src/scripts/DSDialogs.pm \
- ldap/admin/src/scripts/Setup.pm \
ldap/admin/src/scripts/Migration.pm \
ldap/admin/src/scripts/DSMigration.pm \
ldap/admin/src/scripts/FileConn.pm \
@@ -942,16 +941,23 @@ libstatechange_plugin_la_LDFLAGS = -avoid-version
# libsyntax-plugin
#------------------------
libsyntax_plugin_la_SOURCES = ldap/servers/plugins/syntaxes/bin.c \
+ ldap/servers/plugins/syntaxes/bitstring.c \
ldap/servers/plugins/syntaxes/ces.c \
ldap/servers/plugins/syntaxes/cis.c \
ldap/servers/plugins/syntaxes/debug.c \
ldap/servers/plugins/syntaxes/dn.c \
+ ldap/servers/plugins/syntaxes/deliverymethod.c \
+ ldap/servers/plugins/syntaxes/facsimile.c \
+ ldap/servers/plugins/syntaxes/guide.c \
ldap/servers/plugins/syntaxes/int.c \
+ ldap/servers/plugins/syntaxes/nameoptuid.c \
ldap/servers/plugins/syntaxes/numericstring.c \
ldap/servers/plugins/syntaxes/phonetic.c \
ldap/servers/plugins/syntaxes/sicis.c \
ldap/servers/plugins/syntaxes/string.c \
ldap/servers/plugins/syntaxes/tel.c \
+ ldap/servers/plugins/syntaxes/telex.c \
+ ldap/servers/plugins/syntaxes/teletex.c \
ldap/servers/plugins/syntaxes/validate.c \
ldap/servers/plugins/syntaxes/validate_task.c \
ldap/servers/plugins/syntaxes/value.c