summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 8e4c9c9..1fa9361 100644
--- a/configure.ac
+++ b/configure.ac
@@ -65,18 +65,18 @@ AC_CHECK_LIB(ncurses,initscr)
dnl Check for basic OCaml environment & findlib.
AC_PROG_OCAML
AC_PROG_FINDLIB
+if test "x$OCAMLFIND" = "x"; then
+ AC_MSG_ERROR([Cannot find required program 'ocamlfind' (part of findlib)])
+fi
dnl Check for required OCaml packages.
AC_CHECK_OCAML_PKG(unix)
if test "x$pkg_unix" != "xyes"; then
AC_MSG_ERROR([Cannot find required OCaml package 'unix'])
fi
-AC_CHECK_OCAML_PKG(extlib)
-if test "x$pkg_extlib" != "xyes"; then
- AC_MSG_ERROR([Cannot find required OCaml package 'extlib'])
-fi
dnl Check for optional OCaml packages.
+AC_CHECK_OCAML_PKG(extlib)
AC_CHECK_OCAML_PKG(lablgtk2)
AC_CHECK_OCAML_PKG(curses)
AC_CHECK_OCAML_PKG(gettext)