summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorrjones@thinkpad.home.annexia.org <rjones@thinkpad.home.annexia.org>2008-02-12 20:22:43 +0000
committerrjones@thinkpad.home.annexia.org <rjones@thinkpad.home.annexia.org>2008-02-12 20:22:43 +0000
commit627e6f64b0cd359a8f03d45ab093592f000cf6e6 (patch)
tree9ec255374fe72f39110032502b151d8070137923 /configure.ac
parent8f0f6bf5ad24e6b8a92533efa9b35d9850cfccc0 (diff)
downloadvirt-top-627e6f64b0cd359a8f03d45ab093592f000cf6e6.tar.gz
virt-top-627e6f64b0cd359a8f03d45ab093592f000cf6e6.tar.xz
virt-top-627e6f64b0cd359a8f03d45ab093592f000cf6e6.zip
Support for calendar >= 2.0
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 8 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index e246934..4a83490 100644
--- a/configure.ac
+++ b/configure.ac
@@ -166,7 +166,12 @@ if test "x$OCAMLFIND" != "x"; then
AC_CHECK_OCAML_PKG(gettext)
AC_CHECK_OCAML_PKG(xml-light)
AC_CHECK_OCAML_PKG(csv)
- AC_CHECK_OCAML_PKG(calendar)
+
+ dnl Need to check which version of calendar is installed.
+ AC_CHECK_OCAML_MODULE(calendar,pkg_calendar2,CalendarLib.Date,[+calendar])
+ if test "x$pkg_calendar2" = "xno"; then
+ AC_CHECK_OCAML_PKG(calendar)
+ fi
AC_SUBST(pkg_unix)
AC_SUBST(pkg_extlib)
@@ -176,6 +181,7 @@ if test "x$OCAMLFIND" != "x"; then
AC_SUBST(pkg_xml_light)
AC_SUBST(pkg_csv)
AC_SUBST(pkg_calendar)
+ AC_SUBST(pkg_calendar2)
else
dnl Use a basic module test if there is no findlib ...
@@ -192,6 +198,7 @@ else
AC_CHECK_OCAML_MODULE(gettext,pkg_gettext,Gettext,[+gettext]) dnl XXX
AC_CHECK_OCAML_MODULE(xml-light,pkg_xml_light,Xml,[+xml-light])
AC_CHECK_OCAML_MODULE(csv,pkg_csv,Csv,[+csv])
+ dnl XXX Version check - see above.
AC_CHECK_OCAML_MODULE(calendar,pkg_calendar,Calendar,[+calendar])
fi