summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRichard W.M. Jones <rjones@redhat.com>2008-01-07 11:19:38 +0000
committerRichard W.M. Jones <rjones@redhat.com>2008-01-07 11:19:38 +0000
commitf2bb550da8353a7ab11d487b947ed702aa9a838f (patch)
tree842ab8a94770da28b35f6a2f724ed58cdab92f1d /configure.ac
parent643aa9f6fea233073384cdb01e8b23c693bf50e6 (diff)
downloadvirt-top-f2bb550da8353a7ab11d487b947ed702aa9a838f.tar.gz
virt-top-f2bb550da8353a7ab11d487b947ed702aa9a838f.tar.xz
virt-top-f2bb550da8353a7ab11d487b947ed702aa9a838f.zip
Basic framework for NSIS.
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 63ef06f..f0ec22a 100755
--- a/configure.ac
+++ b/configure.ac
@@ -147,6 +147,21 @@ AC_SUBST(subdirs)
dnl Check for optional perldoc (for building manual pages).
AC_CHECK_PROG(HAVE_PERLDOC,perldoc,perldoc)
+dnl Check for optional NSIS.
+AC_ARG_WITH([nsis],
+ [AS_HELP_STRING([--with-nsis],
+ [use NSIS to build a Windows installer])],
+ [],
+ [with_nsis=no])
+MAKENSIS=
+if test "x$with_nsis" != "xno"; then
+ AC_PATH_PROG(MAKENSIS,makensis,[],[$with_nsis:$PATH])
+ if test "x$MAKENSIS" = "x"; then
+ AC_MSG_FAILURE([--with-nsis was given, but could not find MAKENSIS.EXE])
+ fi
+fi
+AC_SUBST(MAKENSIS)
+
dnl Summary.
echo "------------------------------------------------------------"
echo "Thanks for downloading" $PACKAGE_STRING