summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRichard W.M. Jones <rjones@redhat.com>2008-01-18 18:43:20 +0000
committerRichard W.M. Jones <rjones@redhat.com>2008-01-18 18:43:20 +0000
commit43b894e0ef93f380dcd8b1b20a3cd6626a8f3b7d (patch)
treeaa007bd306678022f2441ee290326c1a64d60027 /configure.ac
parentebb4ff16c73674ef768674c85f600b71b63448e7 (diff)
downloadvirt-top-43b894e0ef93f380dcd8b1b20a3cd6626a8f3b7d.tar.gz
virt-top-43b894e0ef93f380dcd8b1b20a3cd6626a8f3b7d.tar.xz
virt-top-43b894e0ef93f380dcd8b1b20a3cd6626a8f3b7d.zip
Move to autogeneration of many C bindings.
* configure.ac, libvirt/libvirt_c.c, libvirt/generator.pl: Many C bindings can now be autogenerated using a Perl script. Also includes preliminary support for the experimental storage API.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac54
1 files changed, 54 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8158440..0fe2bda 100644
--- a/configure.ac
+++ b/configure.ac
@@ -80,8 +80,62 @@ AC_CHECK_FUNCS([virConnectGetHostname \
virDomainSetSchedulerParameters \
virNodeGetFreeMemory \
virNodeGetCellsFreeMemory \
+ virJobGetInfo \
+ virJobGetDomain \
+ virJobGetNetwork \
+ virJobCancel \
+ virJobFree \
+ virDomainCreateLinuxJob \
+ virDomainSaveJob \
+ virDomainRestoreJob \
+ virDomainCoreDumpJob \
+ virDomainCreateJob \
+ virNetworkCreateXMLJob \
+ virNetworkCreateJob \
+ virStoragePoolGetConnect \
+ virConnectNumOfStoragePools \
+ virConnectListStoragePools \
+ virConnectNumOfDefinedStoragePools \
+ virConnectListDefinedStoragePools \
+ virConnectDiscoverStoragePools \
+ virStoragePoolLookupByName \
+ virStoragePoolLookupByUUID \
+ virStoragePoolLookupByUUIDString \
+ virStoragePoolLookupByVolume \
+ virStoragePoolCreateXML \
+ virStoragePoolDefineXML \
+ virStoragePoolUndefine \
+ virStoragePoolCreate \
+ virStoragePoolDestroy \
+ virStoragePoolShutdown \
+ virStoragePoolFree \
+ virStoragePoolRefresh \
+ virStoragePoolGetName \
+ virStoragePoolGetUUID \
+ virStoragePoolGetUUIDString \
+ virStoragePoolGetInfo \
+ virStoragePoolGetXMLDesc \
+ virStoragePoolGetAutostart \
+ virStoragePoolSetAutostart \
+ virStoragePoolNumOfVolumes \
+ virStoragePoolListVolumes \
+ virStorageVolGetConnect \
+ virStorageVolLookupByName \
+ virStorageVolLookupByKey \
+ virStorageVolLookupByPath \
+ virStorageVolGetName \
+ virStorageVolGetKey \
+ virStorageVolCreateXML \
+ virStorageVolDestroy \
+ virStorageVolFree \
+ virStorageVolGetInfo \
+ virStorageVolGetXMLDesc \
+ virStorageVolGetPath \
])
+dnl Check for optional types added since 0.2.1.
+AC_CHECK_TYPES([virJobPtr, virStoragePoolPtr, virStorageVolPtr])
+
dnl We also use <libvirt/virterror.h>
AC_CHECK_HEADER([libvirt/virterror.h],
[],