summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRichard W.M. Jones <rjones@redhat.com>2008-01-04 16:25:24 +0000
committerRichard W.M. Jones <rjones@redhat.com>2008-01-04 16:25:24 +0000
commit1e65c6c293a0f7917e87438330e2583bd38758dd (patch)
tree136898f0cb83f8c79d6dada4f627db29728693fa /configure.ac
parenta8e571097acd0624c6803c878d09c930055cfd39 (diff)
downloadvirt-top-1e65c6c293a0f7917e87438330e2583bd38758dd.tar.gz
virt-top-1e65c6c293a0f7917e87438330e2583bd38758dd.tar.xz
virt-top-1e65c6c293a0f7917e87438330e2583bd38758dd.zip
Make extlib an optional dependency.
* Makefile.in, README, configure.ac, examples/Makefile.in, libvirt/Makefile.in, mlvirtmanager/Makefile.in: Much code doesn't really need extlib, so make it optional. Bail earlier in configure step if we don't have ocamlfind.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 8e4c9c9..1fa9361 100644
--- a/configure.ac
+++ b/configure.ac
@@ -65,18 +65,18 @@ AC_CHECK_LIB(ncurses,initscr)
dnl Check for basic OCaml environment & findlib.
AC_PROG_OCAML
AC_PROG_FINDLIB
+if test "x$OCAMLFIND" = "x"; then
+ AC_MSG_ERROR([Cannot find required program 'ocamlfind' (part of findlib)])
+fi
dnl Check for required OCaml packages.
AC_CHECK_OCAML_PKG(unix)
if test "x$pkg_unix" != "xyes"; then
AC_MSG_ERROR([Cannot find required OCaml package 'unix'])
fi
-AC_CHECK_OCAML_PKG(extlib)
-if test "x$pkg_extlib" != "xyes"; then
- AC_MSG_ERROR([Cannot find required OCaml package 'extlib'])
-fi
dnl Check for optional OCaml packages.
+AC_CHECK_OCAML_PKG(extlib)
AC_CHECK_OCAML_PKG(lablgtk2)
AC_CHECK_OCAML_PKG(curses)
AC_CHECK_OCAML_PKG(gettext)