| Commit message (Collapse) | Author | Age | Files | Lines |
... | |
| |
|
|
|
|
| |
This is just code motion.
|
|
|
|
|
| |
Remove internal structures, fix it so it works with the new
code layout under src/
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
| |
This file had grown by accretion to include:
- code related to handles (now in src/handle.c)
- safe allocation (src/alloc.c)
- debug, errors, warnings (src/errors.c)
- private data (src/private-data.c)
- miscellaneous functions (src/canonical-name.c, src/utils.c)
This commit also removes about a dozen #include files which were
probably not really used.
This is just code motion.
|
|
|
|
| |
This fixes commit 1efed122c07792f4c66a4083159cfacfb1893212.
|
| |
|
| |
|
|
|
|
| |
This fixes commit 1efed122c07792f4c66a4083159cfacfb1893212.
|
|
|
|
|
|
|
|
|
|
| |
If you have a function which is in the X optgroup, and also has
IfAvailable X, then two tests for the optgroup are added to the
output.
Check for this case and give an error.
This also fixes existing APIs.
|
|
|
|
| |
No functional change.
|
|
|
|
|
|
| |
Replace the custom error handler with calls to
guestfs_{push,pop}_error_handler only where necessary. This
simplifies the generated code.
|
|
|
|
| |
This is just code motion.
|
|
|
|
| |
Just code cleanup, no functional change.
|
| |
|
|
|
|
| |
This is just whitespace changes in the output.
|
|
|
|
|
|
| |
In the fork (usual) case, we still won't see any errors since stderr
has been redirected to /dev/null, but this way is still a little more
correct.
|
|
|
|
|
| |
This is a shorter and more convenient way to disable errors
temporarily across calls.
|
|
|
|
|
| |
This is less efficient than directly manipulating g->error_cb, but
easier to maintain.
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
| |
guestfs_pop_error_handler.
The addition of these calls makes it much simpler to temporarily
disable or ignore errors:
guestfs_push_error_handler (g, NULL, NULL);
guestfs_mkdir (g, "/foo"); /* We don't care if this fails. */
guestfs_pop_error_handler (g);
Note these calls are used by the C API only. They are not necessary
in other languages, because those map errors to exceptions.
The subsequent commits change existing code to use push/pop instead of
laboriously saving and restoring the error handler.
|
|
|
|
| |
This is just a whitespace change.
|
| |
|
|
|
|
| |
This fixes commit 9466060201600db47016133d80af22eb38091a49.
|
|
|
|
| |
This fixes commit 1efed122c07792f4c66a4083159cfacfb1893212.
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
| |
New APIs: set-tmpdir, get-tmpdir, set-cachedir, get-cachedir.
The current code has evolved over time and has a number of problems:
(a) A single environment variable ($TMPDIR) controls the
location of several directories.
(b) It's hard for the library user to predict which directory
libguestfs will use, unless the user simulates the same internal steps
that libguestfs performs.
This commit fixes these issues.
(a) Now three environment variables control the location of all small
temporary files, and the appliance cache:
For temporary files: $LIBGUESTFS_TMPDIR or $TMPDIR or /tmp.
For the appliance cache: $LIBGUESTFS_CACHEDIR or $TMPDIR or /var/tmp.
The user can also set these directories explicitly through API calls
(guestfs_set_tmpdir and guestfs_set_cachedir).
(b) The user can also retrieve the actual directories that libguestfs
will use, by calling guestfs_get_tmpdir and guestfs_get_cachedir.
These functions are also used internally.
This commit also:
- reworks the internal tmpdir code
- removes the internal (undocumented) guestfs_tmpdir call (replacing
it with calls to the documented guestfs_get_tmpdir API instead)
- changes the ./run script to set LIBGUESTFS_TMPDIR and
LIBGUESTFS_CACHEDIR
- adds a test
- fixes a few places like libguestfs-make-fixed-appliance which
depended on $TMPDIR
|
|
|
|
| |
So that we can trace all the later calls.
|
| |
|
|
|
|
| |
SKIP_TEST_VIRT_FORMAT_SH=1.
|
| |
|
|
|
|
|
|
|
| |
Previously wipefs (the utility) allowed this, but it's obviously a bad
thing to do and the new wipefs gives an error if you try it:
wipefs: error: /dev/VG/LV: probing initialization failed: Device or resource busy
|
| |
|
| |
|
|
|
|
|
|
| |
'ls' (with no argument) is not a valid command.
This fixes commit bad5c7d5a50e7f340d3a5daff59d7f3c18c0ab8f.
|
| |
|
|
|
|
|
|
|
|
| |
Split the functions according to a simple hash across
C.nr_actions_files files (this number can be increased later if
necessary).
This is just code motion.
|
|
|
|
| |
This is just code motion.
|
|
|
|
| |
This is just code motion.
|
| |
|
| |
|
| |
|
|
|
|
| |
This fixes commit 1949016e899b2737525fdc9b6dda451ad9ecbd66.
|
|
|
|
|
| |
RWMJ:
- Update virt-inspector.rng.
|
|
|
|
|
|
| |
RWMJ:
- Fix memory leak in guestfs__inspect_list_applications wrapper.
- Don't document app2_spare* fields.
|
| |
|
| |
|
|
|
|
| |
Also document 'local*' files.
|
|
|
|
|
| |
Specifically tests which involve btrfs, because btrfs is
currently broken upstream (RHBZ#863978).
|
|
|
|
|
|
| |
This just makes it simpler to add extra fields to each struct.
This is code motion.
|
|
|
|
|
|
| |
This is currently done implicitly because of the linker script.
However in order to do symbol versioning, we will have to do
this explicitly at each definition instead.
|
|
|
|
| |
This is just code motion.
|
|
|
|
| |
No change.
|