summaryrefslogtreecommitdiffstats
Commit message (Collapse)AuthorAgeFilesLines
* Version 1.19.23.1.19.23Richard W.M. Jones2012-07-2220-27083/+27594
|
* launch: Add libvirt backend.Richard W.M. Jones2012-07-226-2/+1066
| | | | | | | | | | | | Complete the attach-method libvirt backend. This backend uses libvirt to create a transient KVM domain to run the appliance. Note that this still will only work with local libvirt URIs since the <kernel>, <initrd> and appliance links in the libvirt XML refer to local files, and virtio serial only works locally (limitation of libvirt). Remote support will be added later.
* Add attach-method "libvirt" or "libvirt:<URI>".Richard W.M. Jones2012-07-215-1/+35
| | | | | With this commit, you can set the attach method to libvirt, but calling launch will give an error.
* launch: Make 'drive_name' into a common function.Richard W.M. Jones2012-07-212-5/+5
| | | | This is just code motion.
* appliance: Push appliance building lock into guestfs___build_appliance.Richard W.M. Jones2012-07-212-17/+27
| | | | | | | | | Since we will be calling guestfs___build_appliance from the libvirt code in future, there's no point having two places where we have to acquire the lock. Push the lock down into this function instead. Because "glthread/lock.h" includes <errno.h> we have to add this header to the file too.
* fuse:remove the unused macro when fuse is not availableWanlong Gao2012-07-211-1/+1
| | | | | | Just make gcc happy when fuse is not available. Signed-off-by: Wanlong Gao <gaowanlong@cn.fujitsu.com>
* launch: Abstract attach method operations.Richard W.M. Jones2012-07-206-111/+171
| | | | | | g->attach_ops points to a structure which contains the operations supported by each attach method backend (ie. appliance, unix, etc.).
* launch: Move the command line building code entirely into launch-appliance.c.Richard W.M. Jones2012-07-203-47/+19
| | | | | Although we still use the handle as convenient temporary storage.
* launch: Move guestfs_config API and build list of qemu parameters in handle.Richard W.M. Jones2012-07-206-34/+69
| | | | | | Move and rewrite guestfs_config so it accumulates a list of qemu parameters in the handle. These are added to the appliance at launch time (with attach method == unix:... you'll now get an error).
* launch: Move launch timing / messages code into launch.c.Richard W.M. Jones2012-07-204-77/+78
|
* lib: Use bool (from <stdbool.h>) for a few fields in the handle.Richard W.M. Jones2012-07-201-10/+12
|
* lib: Rearrange fields in guestfs handle.Richard W.M. Jones2012-07-201-39/+38
| | | | Arrange the fields more logically. This is just code motion.
* add-cdrom: Rewrite description emphasising that this API should not be used.Richard W.M. Jones2012-07-201-20/+2
|
* ocaml: Skip mount-local test if /dev/fuse is not writable.Richard W.M. Jones2012-07-201-0/+8
|
* launch: Remove some dead code from the appliance method.Richard W.M. Jones2012-07-191-42/+0
|
* lib: Split launch.c into separate files.Richard W.M. Jones2012-07-196-1245/+1274
| | | | | | | | | | | | | | | | | | | | | | launch-appliance.c contains the code associated with the 'appliance' attach-method. Mostly. In fact there are a few APIs which don't fit so nicely: - config: deprecated API which fiddles with the qemu command line directly - max-disks: depends on the qemu implementation (virtio-scsi or not) - debug-drives: used for testing only launch-unix.c contains the code associated with 'unix:<path>'. launch.c is the common code for launching, along with a few other APIs such as guestfs_add_drive_opts. This commit also reduces the number of headers to just those which are required.
* Remove debug-cmdline API.Richard W.M. Jones2012-07-192-29/+0
| | | | | Note that debug* calls are not part of the stable API and can be removed or changed at any time.
* lib: Use safe_asprintf when constructing attach_method.Richard W.M. Jones2012-07-192-6/+2
| | | | Just a small code cleanup / simplification.
* build: Rename most C files that contain underscore with dash.Richard W.M. Jones2012-07-1934-2759/+2814
| | | | | | | This is just code motion. Some files cannot be renamed. Notably rpcgen input and output files must not contain dash characters, else rpcgen breaks.
* fish: Rename fish/virt.c to fish/domain.cRichard W.M. Jones2012-07-1911-19/+19
| | | | | This file handles the -d option for guestfish and other C command line utilities. Renaming this file makes it less confusing.
* build: Rename src/virt.c to src/libvirtdomain.cRichard W.M. Jones2012-07-193-2/+2
| | | | | This file contains the code implementing guestfs_add_domain (for adding a libvirt domain) so this name is less confusing.
* build: Arrange libguestfs_la_SOURCES in order.Richard W.M. Jones2012-07-191-1/+1
|
* Remove references to long-obsolete Ocaml_inspector module from .gitignore.Richard W.M. Jones2012-07-191-2/+0
|
* podwrapper: Fix setting of GIT_DIR in git subcommand.Richard W.M. Jones2012-07-191-1/+2
| | | | This fixes commit 1e17a32060feb937b3972f61b37f9116ad7d8d9a.
* license: Use latest license files from gnu.org.Richard W.M. Jones2012-07-192-105/+125
| | | | | | | COPYING from https://www.gnu.org/licenses/gpl-2.0.txt COPYING.LIB from https://www.gnu.org/licenses/lgpl-2.1.txt (Note this change shouldn't alter the licensing of libguestfs)
* Version 1.19.22.1.19.22Richard W.M. Jones2012-07-194-6/+6
| | | | | Includes rebuilt gnulib to work around test problems with test-getlogin_r.
* gnulib: Don't include or run getlogin_r test (thanks Jim Meyering).Richard W.M. Jones2012-07-191-1/+5
| | | | | See: https://lists.gnu.org/archive/html/bug-gnulib/2012-07/msg00194.html
* build: Return 77 from skipped tests.Richard W.M. Jones2012-07-1923-41/+45
|
* Version 1.19.21.1.19.21Richard W.M. Jones2012-07-1820-10855/+11360
|
* tests: Rewrite parallel mount-local test in C.Richard W.M. Jones2012-07-186-0/+534
|
* ocaml: Test mount-local, without parallel test.Richard W.M. Jones2012-07-185-115/+22
| | | | | | | | | Unfortunately the parallel test keeps hitting this bug: https://bugzilla.redhat.com/show_bug.cgi?id=838081 which could be a bug in the OCaml runtime. Just test simple mount-local. We will write a parallel test in C to replace this.
* tar-in: Add --no-same-owner flag to tar command when target filesystem ↵Richard W.M. Jones2012-07-181-3/+54
| | | | | | | | | | | | | | | | doesn't support chown (RHBZ#840572). When using tar-in or tools built around it such as virt-make-fs, if the target filesystem is vfat then unpacking the tarball would fail because tar tries to chown(2) files and fails. You would see errors such as: tar: <file>: Cannot change ownership to uid 500, gid 500: Operation not permitted This change detects whether the target filesystem supports chown(2). If not, it adds the --no-same-owner flag to tar to stop it from trying to change the ownership of newly created files.
* daemon: Make 'random_name' into a utility function.Richard W.M. Jones2012-07-183-30/+51
| | | | | This is mostly code motion, although the precise contract of this function changes slightly to make it more generally useful
* virt-make-fs: Suggest guestfish for complex layouts in man page.Richard W.M. Jones2012-07-181-1/+2
|
* build: Change how make.sh, packagelist, excludelist are updated.Richard W.M. Jones2012-07-181-6/+9
| | | | | | Add proper dependencies for these files, but also use 'cmp' to ensure they only get overwritten if the new files have actually changed, so we don't rebuild the appliance unnecessarily.
* New API: add new api xfs_infoWanlong Gao2012-07-189-1/+416
| | | | | | | | | | | | Add xfs_info to show the geometry of the xfs filesystem. Signed-off-by: Wanlong Gao <gaowanlong@cn.fujitsu.com> RWMJ: - Updated po/POTFILES. - Use xfs_ prefix for all struct fields. - Return uninitialized fields as -1 / empty string. - Copyedit the description.
* augeas: make functions as noreturnWanlong Gao2012-07-181-14/+14
| | | | | | Just make gcc happy. Signed-off-by: Wanlong Gao <gaowanlong@cn.fujitsu.com>
* podwrapper: Use UTF8 in output, send errors to stderr.Richard W.M. Jones2012-07-171-1/+2
| | | | This fixes commit 1e17a32060feb937b3972f61b37f9116ad7d8d9a.
* Version 1.19.20.1.19.20Richard W.M. Jones2012-07-1720-939/+1173
|
* case_sensitive_path: Allow trailing path element to be missing (RHBZ#840115).Richard W.M. Jones2012-07-172-16/+25
| | | | | | | | | | | | case_sensitive_path is undefined when the final path element doesn't exist. Currently it returns an error, but this means that creating a new file doesn't work as expected: $ guestfish --rw -i -d windows touch 'win:c:\blah' libguestfs: error: case_sensitive_path: blah no file or directory found with this name We should allow this case (provided there is no trailing slash) so that new files or directories can be created.
* case_sensitive_path: Move variables to top of function.Richard W.M. Jones2012-07-171-6/+8
| | | | This is just code motion.
* docs: Use L<...> for links.Richard W.M. Jones2012-07-175-31/+27
| | | | | Instead of working around bugs, podwrapper has been fixed so that links work in all output formats.
* podwrapper: Subclass Pod::Man so we can fix the way links are generated.Richard W.M. Jones2012-07-171-5/+22
|
* podwrapper: Define $VERSION in subclass.Richard W.M. Jones2012-07-171-1/+2
| | | | | The superclass sometimes uses this and will give an undefined error if it's missing.
* podwrapper: Tidy up the program name.Richard W.M. Jones2012-07-171-21/+26
| | | | | | | Messages now look like this: podwrapper.pl: wrote guestfs-examples.3 podwrapper.pl: wrote ../html/guestfs-examples.3.html
* perl: In examples, call $g->shutdown, $g->close.Richard W.M. Jones2012-07-172-2/+4
|
* perl: Use $g instead of $h in documentation.Richard W.M. Jones2012-07-178-80/+80
| | | | $g is the "standard" name for libguestfs handles.
* docs: febootstrap is in section 8 of the manual, not section 1.Richard W.M. Jones2012-07-161-1/+1
|
* Replace podwrapper shell script with custom Perl script.Richard W.M. Jones2012-07-165-249/+390
| | | | | | | | This uses Pod::Simple so it properly parses the input POD and can generate proper custom output as required specifically by libguestfs. One immediate benefit is that links between and within manual pages now work mostly correctly.
* Fix pod.css for new HTML output from Perl 5.16.Richard W.M. Jones2012-07-161-9/+9
| | | | | There used to be a <div> around the table of contents, but that is no longer present.