summaryrefslogtreecommitdiffstats
path: root/v2v/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'v2v/Makefile.am')
-rw-r--r--v2v/Makefile.am48
1 files changed, 48 insertions, 0 deletions
diff --git a/v2v/Makefile.am b/v2v/Makefile.am
new file mode 100644
index 00000000..69ed98c0
--- /dev/null
+++ b/v2v/Makefile.am
@@ -0,0 +1,48 @@
+# libguestfs virt-v2v
+# Copyright (C) 2009 Red Hat Inc.
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+
+EXTRA_DIST = \
+ run-v2v-locally \
+ virt-v2v.pl
+
+if HAVE_V2V
+
+man_MANS = virt-v2v.1
+
+noinst_DATA = @top_builddir@/html/virt-v2v.1.html
+
+virt-v2v.1: virt-v2v.pl
+ $(POD2MAN) \
+ --section 1 \
+ -c "Virtualization Support" \
+ --release "$(PACKAGE_NAME)-$(PACKAGE_VERSION)" \
+ $< > $@
+
+@top_builddir@/html/virt-v2v.1.html: virt-v2v.pl
+ mkdir -p @top_builddir@/html
+ cd @top_builddir@ && pod2html \
+ --css 'pod.css' \
+ --title 'virt-v2v, convert virtual machine from Xen to KVM' \
+ --htmldir html \
+ --outfile html/virt-v2v.1.html \
+ v2v/$<
+
+install-data-hook:
+ mkdir -p $(DESTDIR)$(bindir)
+ install -m 0755 virt-v2v.pl $(DESTDIR)$(bindir)/virt-v2v
+
+endif