summaryrefslogtreecommitdiffstats
path: root/tools/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r--tools/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
index d212d380..08f126d5 100644
--- a/tools/Makefile.am
+++ b/tools/Makefile.am
@@ -30,9 +30,12 @@ tools = \
win-reg
EXTRA_DIST = \
+ make-test-img.sh
run-locally \
$(tools:%=virt-%)
+CLEANFILES = test.img
+
if HAVE_TOOLS
bin_SCRIPTS = $(tools:%=virt-%)
@@ -61,4 +64,25 @@ $(top_builddir)/html/virt-%.1.html: virt-%
--outfile html/$<.1.html \
tools/$<
+# Tests.
+
+random_val := $(shell awk 'BEGIN{srand(); print 1+int(255*rand())}' < /dev/null)
+
+TESTS_ENVIRONMENT = \
+ MALLOC_PERTURB_=$(random_val) \
+ LD_LIBRARY_PATH=$(top_builddir)/src/.libs \
+ LIBGUESTFS_PATH=$(top_builddir)/appliance \
+ PERL5LIB=$(top_builddir)/perl/blib/lib:$(top_builddir)/perl/blib/arch
+
+# Build a standard test image to be used by all these tests.
+check_DATA = test.img
+test.img: make-test-img.sh
+ $(TESTS_ENVIRONMENT) $(srcdir)/make-test-img.sh
+
+TESTS = test-virt-cat.sh \
+ test-virt-df.sh \
+ test-virt-list-filesystems.sh \
+ test-virt-ls.sh \
+ test-virt-tar.sh
+
endif