summaryrefslogtreecommitdiffstats
path: root/tests/regressions/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/regressions/Makefile.am')
-rw-r--r--tests/regressions/Makefile.am54
1 files changed, 54 insertions, 0 deletions
diff --git a/tests/regressions/Makefile.am b/tests/regressions/Makefile.am
new file mode 100644
index 00000000..e43d9e9f
--- /dev/null
+++ b/tests/regressions/Makefile.am
@@ -0,0 +1,54 @@
+# libguestfs
+# Copyright (C) 2009-2011 Red Hat Inc.
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+
+include $(top_srcdir)/subdir-rules.mk
+
+TESTS = \
+ rhbz501893 \
+ rhbz503169c13.sh \
+ rhbz557655.sh \
+ rhbz576879.sh \
+ rhbz578407.sh \
+ rhbz580246.sh \
+ rhbz602997.sh \
+ rhbz690819.sh \
+ test-noexec-stack.pl
+
+random_val := $(shell awk 'BEGIN{srand(); print 1+int(255*rand())}' < /dev/null)
+
+TESTS_ENVIRONMENT = \
+ MALLOC_PERTURB_=$(random_val) \
+ LD_LIBRARY_PATH=$(top_builddir)/src/.libs \
+ LIBGUESTFS_PATH=$(top_builddir)/appliance \
+ TMPDIR=$(top_builddir) \
+ PERL5LIB=$(top_builddir)/perl/blib/lib:$(top_builddir)/perl/blib/arch \
+ NOEXEC_CHECK="$(top_builddir)/src/.libs/libguestfs.so $(top_builddir)/daemon/guestfsd"
+
+check_PROGRAMS = \
+ rhbz501893
+
+rhbz501893_SOURCES = rhbz501893.c
+rhbz501893_CFLAGS = \
+ -I$(top_srcdir)/src -I$(top_builddir)/src \
+ $(WARN_CFLAGS) $(WERROR_CFLAGS)
+rhbz501893_LDADD = \
+ $(top_builddir)/src/libguestfs.la
+
+EXTRA_DIST = \
+ $(TESTS) \
+ rhbz557655-expected.stdout \
+ rhbz557655-expected.stderr