summaryrefslogtreecommitdiffstats
path: root/resize/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'resize/Makefile.am')
-rw-r--r--resize/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/resize/Makefile.am b/resize/Makefile.am
index 5227c236..32c1af7e 100644
--- a/resize/Makefile.am
+++ b/resize/Makefile.am
@@ -112,11 +112,12 @@ TESTS = test-virt-resize.sh utils_tests
# Dependencies.
depend: .depend
-.depend: $(wildcard *.mli) $(wildcard *.ml)
+.depend: $(wildcard $(abs_srcdir)/*.mli) $(wildcard $(abs_srcdir)/*.ml)
rm -f $@ $@-t
- $(OCAMLFIND) ocamldep -I ../ocaml $^ | \
+ $(OCAMLFIND) ocamldep -I ../ocaml -I $(abs_srcdir) $^ | \
$(SED) 's/ *$$//' | \
$(SED) -e :a -e '/ *\\$$/N; s/ *\\\n */ /; ta' | \
+ $(SED) -e 's,$(abs_srcdir)/,$(builddir)/,g' | \
sort > $@-t
mv $@-t $@