summaryrefslogtreecommitdiffstats
path: root/rescue/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'rescue/Makefile.am')
-rw-r--r--rescue/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/rescue/Makefile.am b/rescue/Makefile.am
index d0b23cae..6e775d09 100644
--- a/rescue/Makefile.am
+++ b/rescue/Makefile.am
@@ -18,6 +18,7 @@
include $(top_srcdir)/subdir-rules.mk
EXTRA_DIST = \
+ test-virt-rescue.pl \
virt-rescue.pod
CLEANFILES = stamp-virt-rescue.pod
@@ -63,3 +64,11 @@ stamp-virt-rescue.pod: virt-rescue.pod
--license GPLv2+ \
$<
touch $@
+
+# Tests.
+
+TESTS_ENVIRONMENT = $(top_builddir)/run --test
+
+if ENABLE_APPLIANCE
+TESTS = test-virt-rescue.pl
+endif ENABLE_APPLIANCE