summaryrefslogtreecommitdiffstats
path: root/perl/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'perl/Makefile.am')
-rw-r--r--perl/Makefile.am13
1 files changed, 9 insertions, 4 deletions
diff --git a/perl/Makefile.am b/perl/Makefile.am
index 4b7ed993..b7662443 100644
--- a/perl/Makefile.am
+++ b/perl/Makefile.am
@@ -15,17 +15,22 @@
# along with this program; if not, write to the Free Software
# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+include $(top_srcdir)/subdir-rules.mk
+
+generator_built = \
+ Guestfs.xs \
+ lib/Sys/Guestfs.pm \
+ bindtests.pl
+
EXTRA_DIST = \
+ $(generator_built) \
Makefile.PL.in \
- Guestfs.xs \
examples/README \
examples/LICENSE \
examples/*.pl \
- lib/Sys/Guestfs.pm \
lib/Sys/Guestfs/Lib.pm \
run-bindtests \
run-perl-tests \
- bindtests.pl \
t/*.t \
typemap
@@ -42,7 +47,7 @@ TESTS_ENVIRONMENT = \
INSTALLDIRS = site
-all: Makefile-pl
+all: Makefile-pl $(generator_built)
$(MAKE) -f Makefile-pl
Makefile-pl: Makefile.PL