summaryrefslogtreecommitdiffstats
path: root/ocaml/examples/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ocaml/examples/Makefile.am')
-rw-r--r--ocaml/examples/Makefile.am25
1 files changed, 1 insertions, 24 deletions
diff --git a/ocaml/examples/Makefile.am b/ocaml/examples/Makefile.am
index e38a5c8d..c251409b 100644
--- a/ocaml/examples/Makefile.am
+++ b/ocaml/examples/Makefile.am
@@ -1,8 +1,6 @@
EXTRA_DIST = \
LICENSE README \
- lvs.ml \
- viewer.ml xmllight_loader.ml xmllight_loader.mli \
- Throbber.png Throbber.gif
+ lvs.ml
CLEANFILES = throbber.ml *.cmi *.cmo *.cmx *.o lvs
@@ -16,25 +14,4 @@ lvs: lvs.ml
$(OCAMLFIND) ocamlopt $(OCAMLFINDFLAGS) \
-warn-error A -I .. mlguestfs.cmxa $< -o $@
-if BUILD_OCAML_VIEWER
-
-noinst_SCRIPTS += viewer
-
-viewer: throbber.ml xmllight_loader.mli xmllight_loader.ml viewer.ml
- ocamlducefind opt $(OCAMLFINDFLAGS) \
- -warn-error A \
- -thread \
- -package libvirt,lablgtk2,extlib,xml-light,ocamlduce,threads -I .. \
- -predicates init,threads \
- -linkpkg mlguestfs.cmxa gtkThread.cmx \
- $^ -o $@
-
-throbber.ml: Throbber.png Throbber.gif
- gdk_pixbuf_mlsource --build-list \
- static Throbber.png \
- animation Throbber.gif \
- > $@-t && mv $@-t $@
-
-endif
-
endif