summaryrefslogtreecommitdiffstats
path: root/ocaml/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ocaml/Makefile.am')
-rw-r--r--ocaml/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/ocaml/Makefile.am b/ocaml/Makefile.am
index 1aa0cb6a..d65ebaaf 100644
--- a/ocaml/Makefile.am
+++ b/ocaml/Makefile.am
@@ -94,8 +94,9 @@ t/%.cmx: t/%.ml mlguestfs.cmxa
depend: .depend
.depend: $(wildcard *.mli) $(wildcard *.ml)
- rm -f .depend
- $(OCAMLFIND) ocamldep $^ > $@
+ rm -f $@ $@-t
+ $(OCAMLFIND) ocamldep $^ | sed 's/ *$$//' > $@-t
+ mv $@-t $@
include .depend