summaryrefslogtreecommitdiffstats
path: root/java/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'java/Makefile.am')
-rw-r--r--java/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/java/Makefile.am b/java/Makefile.am
index a96d3047..ef78773d 100644
--- a/java/Makefile.am
+++ b/java/Makefile.am
@@ -102,7 +102,11 @@ install-data-hook:
# Tests (not comprehensive).
-TESTS = run-bindtests run-java-tests
+TESTS = run-bindtests
+if ENABLE_APPLIANCE
+TESTS += run-java-tests
+endif ENABLE_APPLIANCE
+
TESTS_ENVIRONMENT = \
JAVA=$(JAVA) \
CLASSPATH=.:t:libguestfs-$(VERSION).jar \