summaryrefslogtreecommitdiffstats
path: root/inspector/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'inspector/Makefile.am')
-rw-r--r--inspector/Makefile.am18
1 files changed, 16 insertions, 2 deletions
diff --git a/inspector/Makefile.am b/inspector/Makefile.am
index 6b937d3a..5e6828f8 100644
--- a/inspector/Makefile.am
+++ b/inspector/Makefile.am
@@ -18,8 +18,10 @@
include $(top_srcdir)/subdir-rules.mk
EXAMPLE_XML = \
- example1.xml example2.xml example3.xml \
- example4.xml example5.xml example6.xml
+ example-debian.xml \
+ example-fedora.xml \
+ example-ubuntu.xml \
+ example-windows.xml
EXTRA_DIST = \
run-inspector-locally \
@@ -61,6 +63,18 @@ TESTS_ENVIRONMENT = $(XMLLINT) --noout --relaxng virt-inspector.rng
endif
+# These rules require virt-inspector so there is no good time that we
+# can run them. Instead you can run them by hand.
+
+example-debian.xml:
+ ./run-inspector-locally ../images/debian.img > $@
+example-fedora.xml:
+ ./run-inspector-locally ../images/fedora.img > $@
+example-ubuntu.xml:
+ ./run-inspector-locally ../images/ubuntu.img > $@
+example-windows.xml:
+ ./run-inspector-locally ../images/windows.img | fgrep -v '<uuid>' > $@
+
endif
# Make symlink from virt-inspector.pl to virt-inspector. This is just