summaryrefslogtreecommitdiffstats
path: root/images/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'images/Makefile.am')
-rw-r--r--images/Makefile.am13
1 files changed, 12 insertions, 1 deletions
diff --git a/images/Makefile.am b/images/Makefile.am
index 68111071..dcdf51f8 100644
--- a/images/Makefile.am
+++ b/images/Makefile.am
@@ -18,4 +18,15 @@
EXTRA_DIST = \
helloworld.tar \
helloworld.tar.gz \
- mbr-ext2-empty.img.gz
+ mbr-ext2-empty.img.gz \
+ empty known-1 known-2 known-3
+
+noinst_DATA = test.sqsh
+
+CLEANFILES = test.sqsh
+
+squash_files = helloworld.tar helloworld.tar.gz empty known-1 known-2 known-3
+
+test.sqsh: $(squash_files)
+ rm -f $@
+ $(MKSQUASHFS) $(squash_files) $@