summaryrefslogtreecommitdiffstats
path: root/fish/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'fish/Makefile.am')
-rw-r--r--fish/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/fish/Makefile.am b/fish/Makefile.am
index 6c856713..f6354c40 100644
--- a/fish/Makefile.am
+++ b/fish/Makefile.am
@@ -99,10 +99,10 @@ guestfish_SOURCES = \
tilde.c \
time.c
-# This convenience library is solely to avoid compiler warnings
-# in its generated sources.
-librc_protocol_la_SOURCES = rc_protocol.c
-librc_protocol_la_CFLAGS = -Wall -Wno-unused
+# This convenience library is solely to compile its generated sources with
+# custom flags.
+librc_protocol_la_SOURCES = rc_protocol.c rc_protocol.h
+librc_protocol_la_CFLAGS = -Wall -Wno-unused -fno-strict-aliasing
# Build the command lookup perfect hash code. The generated code has
# lots of warnings so we must compile it in a separate mini-library.